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If you need a simple, affordable, reliable solution to
automating your broadcasting needs, RadioBOSS is the
solution you've been look ing for.

Whether it's building and scheduling crossfaded programming
for your terrestrial or Internet radio station, creating the right
audio atmosphere in your restaurant or store, or broadcasting
from live events, RadioBOSS has been the choice of
thousands of broadcasters just like you for the past five
years. 

RadioBOSS makes it easy and fast to convert and manage
audio assets, build playlists with advertising support, hourly
blocks, rotations, crossfading, automatic leveling and other
professional-level features and play your playlists to your
local, terrestrial or Internet broadcasting system.
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1 Introduction

RadioBOSS is a professional radio automation software for terrestrial and Internet radio stations, DJ

discos, clubs, bars, restaurants, casinos, health clubs and other venues. Once the playlist is set and

settings are configured, the program allows broadcasting 24 hours a day in a fully unattended mode.

RadioBOSS offers many tools and options to produce a professional music program, including playlist

generator, playback scheduler, advertisement scheduler, voiceovers, teasers, internet radio broadcasting,

music library and many other features. All features are delivered in an intuitive, user-friendly interface

that allows you to learn the software quickly and use it with remarkable ease. 

This help file is for RadioBOSS 7.1

Copyright 2025 DJSoft.Net. All rights reserved.

RadioBOSS is the property of DJSoft.Net and is protected by international copyright law.

https://www.djsoft.net
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2 How to register

RadioBOSS is distributed on a try-before-you-buy basis. You can download a trial version of the

application and use it for free during the trial period. To continue using RadioBOSS after the trial is over,

you must buy a registration key.

To register RadioBOSS, follow the steps below:

1. Go to www.djsoft.net and click the Buy button. 

RadioBOSS is available in three editions. For details, please see the comparison table:

http://www.djsoft.net/enu/radioboss_editions.htm (You can upgrade your edition any time at no

additional cost.)

Once your order is submitted and processed, a message with the registration data will be sent to your

email address specified during the registration.

2. Open RadioBOSS, and select Help -> Enter Registration Code... in the top menu bar. 

3. A dialog prompting you to enter a registration key will open:

4. Enter your registration key. It is advisable to copy and paste the code from the email message.

If you lost your license code, please visit this link to restore it:

https://www.djsoft.net/enu/resendlicense.htm

5. Click OK. Now your copy of the application is registered and all limitations are removed.

https://www.djsoft.net/
http://www.djsoft.net
http://www.djsoft.net/enu/radioboss_editions.htm
https://www.djsoft.net/enu/resendlicense.htm
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If you have upgraded your edition (e.g. from Express to Standard), repeat steps 1 to 5 for the changes to

take effect.

More information:

RadioBOSS. Quick start
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3 Quick start

RadioBOSS lets you get started in just a few easy steps.

1. Run RadioBOSS. By default, additional information for music tracks is stored in the SQLite database.

There are other options, please see this page for the details: Additional information storage

2. Set up Music Library. Music Library is used for quick-search and automatic playlist generation. 

If you are not going to use these features, you can skip this step. (You can use RadioBOSS without using

Music Library.)

In the top menu bar, select Tools -> Music Library. 

The Music Library window will open:

To add a folder containing music tracks, click Add -> Add folder. Add your music using the "Add..."

commands.

Once added, the audio files will be listed in the music library along with their track information (artist,

title, album, year, genre, etc.)

Close the music library.
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3. Adding music to the playlist. You can use the Playlist menu or file explorer shown on the left

(using drag-and-drop).

Available menu commands: 

 

RadioBOSS supports multiple playlists, and you can add as many playlists as you need by clicking the “+”

button (shown on the right). The button also lets you add a Cart wall or Web browser.

4. Assigning quick-access jingles. Select Jingles > Assign... to add jingles, so that you can play

them by pressing the keys 1–9 on the keyboard.
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5. Set up crossfading. You can skip this step and use the default settings. 

In the menu, click Settings -> Crossfades. You can find more information here: Crossfading.

6. If you have multiple sound cards installed or want to configure advanced playback settings, go to the

Settings window from the menu: Settings -> Options...

In the playback section, you can set up output sound cards and various output settings. 

You can also configure pre-listening of a track. This way, you will be able to listen to that track without

broadcasting it, on a separate audio device.

Read more here: playback parameters.
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7. Setting up a broadcast. If you are running an Internet radio station, set up the broadcasting

encoders. RadioBOSS supports ShoutCast, IceCast, and compatible servers. It also supports Windows

Media Server and has a built-in broadcasting server, so that users can connect directly to RadioBOSS. No

extra plugins are required. The Broadcasting Internet Radio section describes in detail how to set up

broadcasting encoders.

8. Set up Hot Keys. Most hot keys are on by default: you can disable or reassign hot keys to suit your

needs.

9. To start the playback, double-click any file in the playlist.

More information:

Broadcasting encoders

Creating a music library

Generating a playlist
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3.1 Setting up PFL

Pre-listening is available in the playlist (right-click a track) and the music database, as well as in Track

Tool, the crossfade editor, and the voice track recorder.

To configure pre-listening, open the application’s settings, switch to the Playback section, and select a

device for pre-listening tracks for the Pre-listening (PFL) card. 
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4 Operation

4.1 Broadcasting Internet radio

RadioBOSS lets you set up your own Internet radio station. The program can send audio stream to a

Shoutcast, Icecast or Windows Media Server to broadcast it out to listeners. The software reads the

audio data from a playlist and encodes it on the fly. It's possible to set up any number of broadcasting

encoders.

To broadcast an Internet radio, follow the steps below:

1. In the top menu bar, select Settings -> Options...

2. In the Settings window, select Broadcast, Metadata

Fill in your station info: station name, description, URL, genre, and other parameters. This is the global

station information and is used for all encoders. Any encoder can override this information if needed.

3. To add a new encoder, select Broadcast on the left, and press the “+” button. 

4. The encoder window will open.
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You can use the Configuration Wizard or enter all connection details manually.

Server address and password are provided by your stream hosting provider (unless you are using

your own server). You can usually find this information on the hosting control panel. If you don't have a

hosting radio, you can get it on the website: https://www.radioboss.fm/

Sample rate, Encoder type, Bitrate, and Channels set the broadcasting format. Please consult with

your stream hosting provider about which format to use. If you are not sure, leave the default one: 44100

MP3 128kbps stereo.

The Station Info tab allows you to override the global station information for the encoder.

The Metadata tab allows you to specify the parameters of track name submission to the server.

The Statistics tab allows you to change the method of obtaining statistics (number of listeners) for the

server; please see this page for the details.

Once you have entered all the settings, press OK. The encoder will be added to the encoders list. 

5. In the Settings window, check the check boxes for all encoders that you want to use. Remember to

turn on the “Broadcasting enabled” option on the top.

http://www.radioboss.fm/
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6. Press OK to close the window.

On successful connection, the report in the bottom-left corner will show the following message:

Connected to server! (output N). It means that listeners can connect to the streaming server and

listen to your radio.

If the broadcast is sent to a port different from the listening port, you will need to configure Statistic

Relays to obtain information about the number of listeners.

If the setup is incorrect, RadioBOSS will show an error message in the report. The error message will

describe the problem and show the number of the encoder that failed to start (e.g. “output 1”).

If this is the case, open the Settings window, select that encoder in the list, and click the Edit button to fix

the configuration.

You can view audience statistics in the Statistics window. To open it, click “Tools” –> “Broadcasting

statistics...” or click the “Statistics” button on the toolbar. Statistics can also be added to work zones

("Statistics" tab type).
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Most common error messages:

Cannot start broadcasting (output N): Error 2100

The specified password is incorrect. Please check the password.

Cannot start broadcasting (output N): Error 2

The server is not available or the specified server address is incorrect. The problem is probably caused

by entering an incorrect address or port. Unless you are using Windows Media Services, make sure that

there is no “http://” or “ftp://” in the server address.

Other reasons: Some anti-virus software or a firewall is blocking the connection, or no network

connection is present.

Cannot start broadcasting (output N): Error -1

The most common reason for this error: Someone is already connected to the server.

Once the broadcasting properties are properly configured, RadioBOSS will broadcast whatever is

currently playing(*) via the Internet radio station in real time.

(*) The Source drop down box (located above the encoders list) selects the sound source for

broadcasting encoders:

Audio mix Whatever is playing in the playlist, will be encoded (this is the default

setting).

Input 1

Input 2

Input 1 or Input 2 will be used as a source. This setting is useful if you

have a mixer board and want to broadcast its output. In this case, the

mixer board should be connected to the corresponding sound card input.

You can configure the inputs via the Settings: Input.
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More information:

Creating a music library

Generating a playlist

Broadcast settings

4.1.1 Statistic relays

The function allows to customize the method of obtaining statistics (number of connected listeners).

By default, statistics are taken from the broadcast server. This doesn’t require any additional setup. 

You can also obtain statistics from another server. This can be useful, when broadcasting is maintained

by one server, while listeners are connected to the other one: such situation is typical of distributed

servers, or systems that support auto DJ, or multiple DJs broadcast from different locations.

To retrieve statistics without broadcasting to the server, on the Connection tab leave the Server field

empty.

To obtain statistics from another server, click Settings -> Options in the menu -> choose Broadcast -

> Double click the right connection to open it, and choose Statistics tab.

Select the Specify the server to get the statistics from.

Choose a server type – Shoutcast or Icecast; this is the type of server, from which statistics are

obtained.

In the Server field, enter server address (without http://), e.g.: example.com:9000.

Password is a server password, which is either admin password or broadcasting password, depending

on the server. To retrieve global stats info from Icecast server, set the Password field to
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admin:PASSWORD (where PASSWORD is the admin password for Icecast server) and leave mount point

field empty.

Mount/Stream ID is the mount name (which is necessary for Icecast) or stream ID for Shoutcast (if ID

is not specified, total number of listeners at the server is returned). 

If everything has been set up correctly, the statistics window shows number of listeners. Otherwise, an

error message is returned in the table instead of number of listeners.

4.1.2 Integrated server

RadioBOSS has a built-in broadcast server. The server allows listeners to connect directly to RadioBOSS

in order to listen to the stream. A built-in server is usually used for the transmission of audio within a

local area network or for signal transmission between affiliate stations. We do not recommend using it

for broadcasting internet radio as the server's functionality is limited.

To activate the server, use the broadcast setup wizard and select the "Configuration Wizard" option.
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Specify the port on which the server will run and the maximum number of listeners.

You can listen to the stream at http://ip-address:port, where "ip-address" is the address of a computer

in the local network or a static IP on the internet, and "port" is the port that was selected when

configuring the server.

SSL streaming support

If you want to allow https:// connections, open the settings folder (using menu Settings, Open Settings

Folder) and add certificate file server_cert.pem - the file needs to be in PEM format. It can include

intermediate and root certificates (in that order) after the server's certificate. Also add server_key.pem

file containing a private (in PEM format) for the certificate. RadioBOSS needs to be restarted after the

certificate files are added.

4.1.3 RTMP streaming

To stream using an RTMP protocol (services like YouTube, Facebook, and others use RTMP), please do

the following.

1. In the top menu bar, select Settings -> Options...

2. In the Settings window, select Broadcast

Click the Custom Encoders button.

http://ip-address:port
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3. In the custom encoders window, click the + button to add a new encoder. Set the encoder name, e.g.

"ENC1", and click the RTMP button.

4. Input the streaming details: RTMP Output URL and Stream Key - this data is provided by the service

you're streaming to.

5. Specify the image or video file to be used as a background. 

6. If you haven't yet installed the plugin, click the Install plugin button. 
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7. Click OK in the RTMP window and then OK in the custom encoders window.

8. In the Broadcast area, add a new streaming encoder (click +). 
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9. Enter [rtmp] into the Server field.

10. In the Encoder field, select the custom encoder that was created previously e.g., "ENC1".
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11. Click OK.

See also Broadcasting Internet radio

4.2 Scheduling playback

RadioBOSS lets you schedule tracks for automatic playback at predefined times. You can use the

scheduler to insert announcements and advertisements into the playback. The scheduler can play single

files or playlists, and start Internet streams, linear input and perform various actions.

You can also schedule commands for automatic execution (e.g. take a random playlist or track from a

folder, change the volume, generate a playlist, and more). Most of the commands can be easily

scheduled using the wizard.

To create a scheduler event, follow these steps:

1. In the Control Panel, select the Scheduler tab.

The scheduler tab will open, with a list of all events scheduled.
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Options at the top of the window

· On - activate and deactivate the scheduler.

· Manual. If the Manual option is active, the events will not launch automatically, but only be marked (in

the Manual column). Use the Run now button to start the events manually. Events running the

makelibrary, adsupdate, createbackup, download, weather, run, streamarchive commands

always launch, regardless of the Manual option state.

The List button allows enabling an events filter, save and load scheduled events list to a file, and perform

other tasks on the events list.

2. Click the Add... button. 

The Event dialog will open, where you can configure the scheduling parameters. 
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3. Click the Open button. 

The Open dialog will open, where you can browse through the folders and select a file (track or playlist)

to play.

You can also use the Wizard, which will help you create an action:
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4. Set the date and time.

You can select a specific day and time to play a file only once, or schedule a repeated playback at a

specific time on particular days. The scheduler also provides additional options to fine-tune the playback

according to your preferences.

5. Click OK to save the scheduled task.

The event will be added to the event list in the scheduler window.

Related topics:

Scheduler

Event options

Scheduler commands
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4.2.1 Event

Scheduled event

 
Event window

Playlist/track filename or command: A playlist, music track, or URL to be launched on the schedule. 

This field can contain one of the commands. To easily enter commands or advanced playback actions,

click the Wizard  button.

You can assign multiple actions to an event by clicking the  button. 

Important! Events that perform a command (except the "stop" command), or events with multiple

actions, all of which are commands, are executed immediately at startup (without insertion into a playlist

and without regard to queuing/waiting options).

A file name template can be used in the file name: details

?yyyy current year (4 digits) ?dd day (2 digits)

?yy current year (2 digits) ?hh

?hp

hour

?hh - hour in 24-hour format (2

digits)

?hp - hour in 12-hour format (1 or

2 digits)

?mm month (2 digits) ?nn minute (2 digits)
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?wd or ?

dw

current day of week (2 digits): 01

to 07

?wk week number (2 digits): 01 to 53

?any any text in the file name ?

noeval

if specified, evaluate macro on

playback start; if not specified,

evaluate on event launch

You can use this option to get a different playlist every day with only one scheduler entry.

Example: The command is C:\Playlists\?yyyy-?mm-?dd.m3u and the current date is February 2,

2016. Using the above parameter will open the playlist with the filename C:\Playlists\2016-02-

02.m3u; the next day, it will open C:\Playlists\2016-02-03.m3u and so on.

The date and time can be adjusted using modifiers, the modifier syntax is: ?(+|-)N(y|m|d|h|n)

The modifier is added to the end of the command.

Example: The command is C:\Playlists\?yyyy-?mm-?dd.m3u?+2d (modifier marked in red, it adds

two days to the current date) and the current date is February 2, 2016. Using the above parameter will

open the playlist with the filename C:\Playlists\2012-02-04.m3u; the next day, it will open C:

\Playlists\2012-02-05.m3u and so on.

Modifiers can change: y - year, m - month, d - day, h - hour, n - minute.

Task name: any string that helps you to identify the event in the list (can be left blank).

Group: a group to which an event belongs. This can be left blank - in this case, an event will not belong

to a group, or you can enter a group name (or click the down arrow if you would like to select from the

existing groups). Groups help in keeping the list of events organized.  Click the "Colors" box to select a

group color.

Event Groups can be expanded and collapsed by double-clicking them in the event list.

Colors: event coloring in the list. Click a box to select colors.

The Delete button removes an event from the list.

The Save as New button saves an event as a copy (instead of editing it).

The Set Default button creates standard settings: these settings will be used when adding new events.

Time and Day

In this section, you can specify the time and day of week for launching the track or playlist.

Date and Time fields: Specify the launch date and time. 

Hours - instead of specifying the time, you can select the hours and minutes at which the event will start,

or set multiple start times for the event. To configure, press the [...] button. 
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· Hours - To run the event at different minutes of the hour, the minutes are listed separated by

commas, for example: 15, 35, 55 - the event will run at the selected hours, at the 13th, 35th and 55th

minute of each hour. 

· List of start times - you can specify multiple start times as a list, each start time can be assigned to

a day of the week.

Important! If the Date check box is checked and Week days is unchecked, the track will be launched

only on the date specified. If both Date and Week days check boxes are checked, the date will

determine the start date: The event will be launched on the selected days of week on and after the

specified date. Next to the date field is a button that, when pressed, will allow you to select the "Every

year" option, in which case the event will launch on the selected day every year.

Week days: Specify the days of week for launching an event. This option lets you make a schedule for

the whole week.

Weeks: sets the number of the day of the week of the month when the assignment should come out. For

example, if "2nd" and "Last" are activated and Sunday is set under Week days, the assignment will

come out on the second and last Sundays of the month.

An event can also be started by a DTMF signal. For more information, please refer to this topic.

Expiration 

· Delete event - the event will be deleted on the specified expiration date/time

· Disable event - the event will be disabled on the specified expiration date/time; the event will not be

re-enabled automatically, it can only be done manually

· Expiration - the event will not run after the specified date/time; Every Year option (right-click the

date field or press the down arrow button) allows to run the event every year up to the specified date.

Can be used in combination with Date (see above) to set the date interval when the event will run.

Duration limit

Limit the event playback duration.

Repeat

Repeat every [X] minutes no more than [Y] times: The event will be launched the specified number

of times at equal time intervals. For example, if the option is set to repeat every 15 minutes no more than

10 times, the event will be executed once at the scheduled time (e.g. at 01:05), and then 9 times at 15-

minute intervals (at 01:20, 01:35, 01:50, etc.). A warning icon will appear if repeats exceed 24 hours

(which can then lead to unneeded event launches).

Waiting Options
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Maximum time to wait in the queue: Specify for how much time the event can stay in the playback

queue. If the playback is not started during the specified time, an action will be performed:

· Delete: the tracks will be removed from the queue.

· Play: event will launch and interrupt the currently playing track

This option also can be used together with the Overlay playback feature, in this case overlay playback

will be delayed to start on current track' end. If by the end of the current track more time is left than the

waiting time set, and the action at the end of the waiting period is Start, then the waiting period will not

be completed and the event will be started immediately.

Options

See the Event Options page.

 

More information:

Scheduling playback

Scheduler commands

Event Options

4.2.1.1 Event Options

Options 

Scheduled event options.

Enabled event To temporarily disable the event, uncheck this box.

Send task name instead of

track titles to server

A task name, not individual track titles of the event, will be sent to

the server.

Set artwork Set the cover art for tracks started with this event (artwork export

to a file or FTP, and notifications).

Do not run if there are

scheduled tracks in the

playlist

If there are scheduled tracks in the playlist, the event will not be

launched.

Do not if the playlist is

stopped

If the playlist is not playing, the event will not be launched.

Insert position Position at which the scheduled event will be inserted into the

playlist, options:

· Queue after the playing track

· Replace playlist
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· Replace scheduled tracks

· Queue after the scheduled tracks

· Insert at the end of the playlist

Insert type Type of the inserted tracks:

Scheduled tracks - track will be inserted into the playlist as

scheduled tracks (marked with the clock icon)

Regular music tracks - tracks will be inserted as regular music

tracks, they won’t be marked with the scheduler “clock” icon; will

not be removed from the playlist after playback; event options

won’t consider those tracks as scheduled tracks. Usually, this should

be enabled for events that start music playlists.

Run scheduled launch

without waiting for current

track to finish

If this option is turned on, the track/playlist will be played at the

time specified in the “Time” field. Otherwise, it will be queued and

played after the current track is finished.

Start earlier to make it end

at Start Time

Event duration will be calculated and event will start earlier to make

playback end at the defined start time. Important! The option only

works if the event starts a single music track.

Insert a sweeper before

starting an event

Insert a sweeper before starting an event. More about sweepers.

Shuffle the playlist before

inserting

If the “Playlist/track filename or command" field contains a playlist

name, the playlist will be shuffled before inserting.

Overlay playback If this option is turned on, the track will be played on its own player,

along with the playlist. You can decrease the volume of the

background music using the music level slider (“Set the playlist level

to”) below.

In the example, the track “Don't Stop” (see screenshot below) is

overlaid on the background music.

Pause the playlist while

event is playing

If this option is turned on, the playlist will be automatically

unpaused when playback is finished. It is useful for announcements

when you don’t want to interrupt the currently playing track.

Priority over the relay The event will silence the currently active relay and play.
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Example: A playlist with the scheduled tracks and “Overlay playback” event playing

4.2.1.2 Sweepers

Sweepers are used to avoid interrupting a song playing before an event starts. For instance, a song

begins to play, but after 20 seconds, a scheduled event is about to start. The event will interrupt the

song. To avoid this situation, RadioBOSS can insert a sweeper; in this case, a 20-second sweeper will

play instead of the song, and then the event will start.

To assign a sweeper: press the "Sweepers..." button in the event window, and select a folder with

sweepers. The more sweepers with different durations the folder contains, the better.
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Maximum time to sweep - sweep at most this amount of time.

Minimum time to sweep - if less than the specified number of seconds remaining until the end of the

track, do not insert the sweeper and allow it to cut the end of the track. This option only works if the

"Allow inserting a sweeper instead of two or more tracks" option is disabled.

There are repeat protection rules for sweepers. To open the repeat protection settings, click the

"Repeat protection" button in the Sweepers window, or use the Playlist -> Extra -> Sweeper

repeat protection menu command. Repeat protection settings are shared for all sweepers.

 

Sweeper selection quality can be controlled in the settings in the Scheduler section.

4.2.2 Scheduler commands

List of available scheduler commands. With some exceptions, the same commands can be called from the

Cart Wall or used directly in the playlist (menu Playlist -> Add command).

Note: The event window has a wizard that can enter most of the commands for you automatically. So

most of the time, there is no need to enter commands manually.

Playback control

· play

· stop
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· pause

· next

· prev

· setvol

· fadeout

· stopoverlays

· eqpreset

· dsp

Playlist

· generate

· getrandomplaylist

· clearplaylist

· [folder_path]

· getfile

· playrequestedsong

· playlist tab

· resetplayedstate

· renderplaylist

Broadcast

· connect

· disconnect

· setencodersource

· setcasttitle

Scheduler

· scheduler on/off

· enablegroup

· disablegroup

· enableevent

· disableevent

· runevent

· setdtmfsource

Relay

· relaystart

· relaystop

Features

· streamarchive

· silencedetector

· enablevo

· disablevo

· autointro

· set
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Ads Scheduler

· adsupdate

· adsremote

Music Library

· makelibrary

System

· run

· reboot

· poweroff

Other

· createbackup

· load

· download

· weather

· COM port

· send

· songrequestclear

play X Play track number X in the

playlist

stop Stop playback

pause Pause playback

next [FadeOut] [CueNextOnEnd] Proceed to the next track. If

FadeOut parameter is

specified, the currently playing

track will be faded out for the

duration specified (in

milliseconds, 1 second = 1000

milliseconds). CueNextOnEnd

modifier makes it wait for the

fading to end, and after that

next track will be played.

Example: start next track

next

Example: start next track and

fade out the current track

during two seconds

next 2000
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Example: fade out current

track for five seconds and start

next track after fading ends

next 5000 CueNextOnEnd

Notice: "next" command with

"CueNextOnEnd" modifier

can be used in multiple action

events as the first command,

in this case it will be executed

before the event is started; it

only works for events with

"Run scheduled launch without

waiting for playing track to

finish" option enabled.

prev Return to the previous track

run filename parameters Launch any program or batch

(.bat) file

Example:

run C:\dosomething.bat

run C:\AnyProgram.exe -

switch1 -switch2

generate preset_name Create a playlist from the

playlist template called

preset_name. For example,

there is a template named

“ROCK 2 Hours” (without

quotes). To generate a playlist

using that template, use the

following command:

generate Rock 2 hours

setvol x Set the volume to X (0 to

100). For example, setvol 70.

Moreover, you can specify the

duration (in milliseconds) for

the volume to reach the

desired level (syntax: setvol

X time_ms). For example,

setvol 70 500 will set the

volume level to 70 over a

period of 0.5 second.



Operation 43

Copyright 2025 DJSoft.Net. All rights reserved.

load filename Load the filename  file. The file

can contain a profile (.prf),

playlist (.m3u), or scheduler

task list (.sdl). If the full

pathname is not specified, the

application will look for a

profile in the \Profile folder,

for a playlist in the \Playlist

folder, and for a scheduler list

in the \Presets\Schedule

folder. A playlist will be loaded

into the Main list.

load text ZN:Name; filename|text Load the text to the tab with a

notebook.

ZN: - zone number (Z2, Z3) 

Name - tab name

filename|text - path to the

file from which the text should

be loaded or the text itself 

Example: load text "this is

test" to NOTE0 tab in zone 2

load text Z2:NOTE0; this is

test

getrandomplaylist Path Load a random playlist from

the folder specified in Path. 

Example:

getrandomplaylist d:

\music\playlists

clearplaylist [up|down] Clear the playlist. If up

modified is specified, will only

remove the tracks above the

currently playing track. If

down modified is specified,

will only remove the tracks

below the currently playing

track.

reboot Restart the system

poweroff Shut down the system and

turn off the power

connect

disconnect

connect — connect to the

broadcasting server. If no

parameters are specified, the
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application will connect to all

servers specified in the

settings. You can use a value

from 1 to N as a parameter for

connecting to a specific server.

Multiple servers can be

specified, comma separated

e.g. connect 1,3,5.

disconnect — disconnect

from the server. The

parameters are the same as

for connect.

scheduler on

scheduler off [timeout]

Temporarily turns on/off the

scheduler. These commands

are useful for live shows.

scheduler off  — suspend

the scheduler. No events will

be started except for ones

with the “scheduler on”

command. Optionally, a

timeout in minutes can be

specified to re-enable the

scheduler, e.g. scheduler off

15 - suspend the scheduler for

15 minutes.

scheduler on  — turn the

scheduler on from the

suspended state. This

command works only if the

scheduler was turned off using

the “scheduler off” command.

It doesn’t work if the scheduler

was turned off manually by

unchecking the “On” check

box.

scheduler on also turns off

the Manual option.

streamarchive on|off

streamarchive FILENAME

streamarchive DURATION FILENAME

Turn on/off the Stream

Archive feature

(menu: Tools -> Stream

Archive)
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streamarchive on - turn on

Stream Archive.

streamarchive off - turn off

recording, including the

second instance (see below)

Start recording and save to

the specified file name:

streamarchive D:

\myshow.mp3

Start recording and save to

the file, limit record duration

to 3600 seconds:

streamarchive 3600 D:

\myshow.mp3

When a file name is specified,

recording is performed in a

second Stream Archive

instance - recording in the

Stream Archive window is

unaffected. If recording

duration is not specified, the

recording can be stopped with

the streamarchive off

command, or by pushing the

Stop button in the Stream

Archive window. If another

recording is started with the

file name specified, it will stop

the current recording being

performed in the second

Stream Archive instance.

makelibrary LibraryName|Dir1|Dir2|...

makelibrary <options> LibraryName|Dir1|Dir2|...

Create or update a music

library. Command parameters

are separated with the |

character.

The first parameter sets music

library name. The second and

following parameters are the

folders to scan (including

subfolders). Instead of path

you can specify playlist, music
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library file or a single music

track. When a folder or a

playlist is specified, the library

will be rebuilt only with tracks

from specified

folders/playlists. When a

single file is specified, it is

added to the library.

Example: Create a music

library file named music, and

add tracks from the “C:\Music”

folder.

makelibrary music|C:

\Music

Example: Same as above, but

adds tracks from the “C:

\Music” and “D:\MoreMusic”

folders:

makelibrary music|C:

\Music|D:\MoreMusic

Example: Using playlist as

source

makelibrary music|C:

\playlist.m3u8

Options specify additional

processing options: scan for

silence, BPM, normalize tracks.

It is recommended to create

command with options using

the Tools->Schedule library

update menu in Music

Library.

Example: normalize tracks

with -9.0 LUFS target; trim

silence; scan for mix point at -

14 dB; detect BPM; detect Mix

Start point at -4 dB. Skip

tracks that already scanned.

makelibrary <normalize:-

9.0;skip|silence:skip|

mixpoint:-14.0;skip|
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bpm:skip|mixstart:-

4.0;skip> music|C:\Music

Example: normalize tracks

with -9.0 LUFS target, skip

tracks with level tag set

makelibrary <normalize:-

9.0;skip> music|C:\Music

Example: normalize tracks

with -9.0 LUFS target; trim

silence; scan for mix point at -

14 dB; detect BPM. Re-scan

tracks where values are set

(no skip modifier)

makelibrary <normalize:-

9.0|silence|mixpoint:-

14.0|bpm> music|C:\Music

Example: same as above, but

also assign NEW and TEST

tags to the tracks

makelibrary <normalize:-

9.0|silence|mixpoint:-

14.0|bpm|tags:NEW;TEST>

music|C:\Music

Example: same as above, but 

assign NEW and TEST tags to

the tracks only if they don't

have any tags

makelibrary <normalize:-

9.0|silence|mixpoint:-

14.0|bpm|

tags_new:NEW;TEST>

music|C:\Music

adsupdate

adsupdate -skipevents

Update advertisement events

and playlists. Executing this

command will produce the

same result as clicking the

“Create playlists and event”

button in Ads Scheduler.

If -skipevents modifier is

present, the command will not

export or update events in
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RadioBOSS, only playlists will

be updated.

adsremote Update advertisement events

and playlists on remote

RadioBOSS installation.

createbackup FileName Create a backup of application

settings and events, saving it

to the specified file. If SQLite

database is used, its backup is

also created.

Example:

createbackup C:

\RB_backup.7z

createbackup C:

\RB_Backup_?yyyy-?mm-?

dd.7z

In the second example, a

substitution macro is used. 

folder_path

folder_path/

Add tracks from a folder to the

playlist. If path ends with "/"

then tracks will be added in

random order, otherwise

tracks will be added in

alphabetic order

Example:

D:\Music or D:\Music\ -

add tracks from D:\Music

folder in an alphabetic order

D:\Music/ - add tracks from

D:\Music folder in random

order
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download [podcast|podcast_today] URL FILENAME Downloads a file from the URL

and saves it as FILENAME

· To trigger a specific URL

(e.g. to send a notification),

without saving any file, omit

the FILENAME parameter.

· If a podcast keyword is

specified, the URL has to

specify the podcast address

and RadioBOSS will select

the newest podcast from the

feed and download it. 

· podcast_today works the

same as podcast keyword

except that it will only

download today's podcast

(no file will be downloaded

in case there's no stream

for today)

· When downloading from

FTP, RadioBOSS will use

Passive mode if username

and password are specified

in the URL, otherwise Active

mode is used.

Example:

download

http://www.example.com/

file1.exe D:\savedfile.ext

Example: download podcast

(will download the newest

podcast from the feed)

download podcast

http://www.example.com/

podcast.xml D:

\podcast.mp3

Example: download podcast

(will download the today's

podcast from the feed)

download podcast_today

http://www.example.com/

podcast.xml D:

\podcast.mp3
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Example: download file

specifying username and

password for authorization

download

http://USERNAME:PASSW

ORD@www.example.com/fil

e1.exe D:\savedfile.ext

Example: call script at

specified URL but do not save

anything

download

http://www.example.com/

thescript.php

fadeout time_ms Fade out the playlist playback

in time_ms milliseconds.

Example: fadeout 500

set com(1-9) (dtr|txd)

clr com(1-9) (dtr|txd)

Set/clear the value at the

com-port out; out can be

either dtr (pin 4) or txd (pin

3). For example: 

set com1 dtr — set high dtr

com1 level; 

clr com2 txd — clear (set low

level) at txd com2 out. Low

com-port level corresponds to

–12V and high level to +12V.

send COMX text Send string text to COM-port

COMX.

COMX - COM port name, e.g.

COM1

text - text to send
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set OPTION [on|off] Enable/disable OPTION.

set OPTION on - enable (turn

on) OPTION.

set OPTION off - disable

(turn off) OPTION.

Example: set shuffle on -

enable shuffle mode; set

shuffle off - disable shuffle

OPTION can be one of the

following: 

shuffle - shuffle (random

playback)

repeat_track - repeat track

option

repeat_list - repeat playlist

option

break - stop after current

track 

autoamp - automatic volume

control (AutoAmp)

http_request - HTTP

request

manual - scheduler Manual

mode

autointro - Auto Intro 

api - remote control API

timestretch - Time Stretch

The set command can also be

used to set a variable value %

showname: 

set %showname=TEXT

The variable value %

showname can be used in

the HTTP request.

setencodersource SRC Change the sound source for

broadcasting encoders. 

Possible SRC values:

0 - Audio mix

1 - Input 1

2 - Input 2



RadioBOSS User Manual52

Copyright 2025 DJSoft.Net. All rights reserved.

3 - Input 3

For more information about

encoder sources please refer

to this page: Broadcasting

Internet radio

Example: 

setencodersource 0

setcasttitle TITLE Update streaming title.

Example:

setcasttitle My Show

silencedetector on

silencedetector off 

Turn on and turn off the

silence detector

silencedetector on – enable

silencedetector off –

disable

This command can also be

used for changing these

parameters:

silencedetector timeout N -

change silence detector

timeout (in seconds)

silencedetector playlist

FILENAME - change the name

of the playlist opened upon

silence detection.

getfile C:\path_to_folder /random|/newest|/oldest|/first

[/delete|/move]

This command adds one file

from the specified folder to the

playlist. It can select the oldest

or newest file (by the adding

date), or a random file. The

command selects music files

and playlist files.

Syntax:

getfile C:\path_to_folder

[/random|/newest|/oldes

t] [/delete]

If a folder path contains

spaces, it must be surrounded

by quotes.
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/random - select a random

track

/newest - select newest

track

/oldest - select oldest track

/first - alphabetically sorts

the file list and selects the first

file

/delete - delete the file after

playback

/move=path - move the file

to the folder "path" after

playback; if the path contains

spaces, the parameter must

be enclosed in quotes:

"/move=C:\path with spaces".

Example: Play one file from

the ads folder, and then delete

that file from disk:

getfile C:

\announcements /newest

/delete

If you prefer to keep the file

after playback, omit the delete

parameter.

playrequestedsong

playrequestedsong N

To automatically play the

requested songs, use the

playrequestedsong

command.

Optionally, you can specify a

minimum time interval (in

minutes) to delay song request

playback: some music

licensing authorities require a

delay before the requested

song can be played. Example:

playrequestedsong 30 -

delay requested song playback

for at least 30 minutes. The

scheduled event with the

playrequestedsong command
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should be set up to repeat,

e.g. every 10 minutes during

the time period when you

want to accept song requests.

See also: Remote Control API

song request actions:

songrequest,

songrequestclear

weather city, country Update weather data:

Automatic weather

announcement

Example: weather New

York, US 

setdtmfsource 1|2|3|URL Set DTMF detector source.

1 - Input 1

2 - Input 2

3 - Input 3

URL - specify network stream

URL

Example: setdtmfsource

http://example.com:8000

stopoverlays Stops all playing "overlay

playback" events

enablegroup GROUP

disablegroup GROUP

Enable (enablegroup) or

disable (disablegroup) a

group of events.

GROUP - event group name to

enable/disable. Multiple

groups can be specified,

comma separated, e.g.

enablegroup Group 1,

Group 2

enableevent EVENTNAME

disableevent EVENTNAME

Enable (enableevent) or

disable (disableevent) an

event.

EVENTNAME - event name

enableevent MyShow
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runevent EVENTNAME|EVENTID Run an event by its name or

identifier.

runevent MyShow - run an

event using its name

runevent MMHDBYQSNUEF -

run an event using its identifier

enablevo

disablevo

Enable or disable Voiceovers.

autointro [disable|enable] rule1, rule2, ... Enable or disable Auto Intro

rules. Rules names are not

case sensitive.

Example: disable rules

Morning and Day

autointro disable Morning,

Day

Example: enable Artist rule

autointro enable Artist

eqpreset NAME Change equalizer preset.

Example: change current

preset to "Rock"

eqpreset Rock

dsp enable|disable [index] Enable or disable DSP

Examples:

dsp enable - enable all DSPs

dsp enable 1 - enable DSP

#1 in the list

dsp disable 1 - disable DSP

#1 in the list

playlist TABNAME Change active playlist tab.

When used inside "Multiple

actions" in the scheduled

event, this command is always

executed first, regardless of its

position in the actions list.

Example: change active

playlist tab to tab named

"Main"
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playlist Main

relaystart 1|2|3|URL Start relaying.

1 - Input 1

2 - Input 2

3 - Input 3

URL - specify network stream

URL

Example: relay network

stream

relaystart

http://example.com/strea

m

Example: relay line input 1

relaystart 1

relaystop Stop relaying.

resetplayedstate Reset the "played track" status

for tracks in the playlist

window.

renderplaylist Format|Samplerate|Channels|Bitrate|FILENAME Render playlist to a file.

Parameters

Format - mp3, ogg, aac, flac,

opus

Samplerate - sample rate

value (e.g. 44100)

Channels - 1 (mono) or 2

(stereo).

Bitrate - bitrate for encoding,

kbps.

Filename - file name (full

path)

Example:

renderplaylist mp3|44100|

2|128|D:\myshow.mp3

songrequestclear [maxage] Clear the list of requested

songs. You can specify the

maximum “age” of requests

(in hours) to be deleted, for

example:
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songrequestclear 4 - delete

requests made more than 4

hours ago.

Without specifying the

parameter, all requests will be

deleted

songrequestclear - delete

all song requests

See also

Scheduler

Remote Control API

4.2.3 Starting events by DTMF signal

Scheduled events can also be started by a DTMF signal. It is useful when you need to rebroadcast

another station and insert regional advertisement blocks: DTMF can be used for synchronization.

DTMF configuration

First, select a source where DTMF will be checked. In the Settings window, select DTMF tab. 

Select an input (Input1/Input 2) or URL. If you selected “URL,” enter a network stream URL; RadioBOSS

will connect to that URL and look for DTMF tones in the stream. 

RadioBOSS will automatically activate or deactivate the DTMF detector when necessary.

Setting up events

In the event properties window, check the DTMF check box and enter a DTMF sequence (e.g. “764C”).

When this sequence is detected, the event will start. 

RadioBOSS starts to look for a DTMF tone 5 minutes before the event start time and ends 5 minutes after

the event start time. The time frame can be adjusted in the DTMF tab in the Settings. For example, if the

event is supposed to start at 01:00:00, DTMF will be checked from 00:55:00 to 01:05:00. If no DTMF is

detected within that time frame, the event will be launched at the end of the DTMF checking window - in

the example, at 01:05:00. To avoid this, check the DTMF Only checkbox: in this case, the events will be

started by DTMF only. If no DTMF tone is detected, the scheduled event will not start. 

To end an event by a DTMF signal, check the “End DTMF” check box and enter a DTMF sequence.

Multiple DTMF signals can be specified for Start and End DTMF, e.g. “764C, 1D56” - in this case the event

will be started by either “764C” or “1D56” tone.
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4.2.4 Events overview

Events Overview window is used to analyze what events will run on a given day. 

To open the Events Overview window, click the List button under the events list, and select the Events

Overview... command.

Each event is shown as a rectangle, its width indicates the event duration. Hovering any event in the

chart will show its name and start time, click on an event to select it in the events list, and double-click

to call the event editor window. Rectangle height doesn't have any special meaning - the heights are

different to prevent one event hiding completely behind another.

4.3 Generating a playlist

Playlist Generator Pro

Playlist Generator Pro can help you create playlists with a given structure (rotation) that will determine

which tracks, from which source(s), and how many ones will show up in the playlist. In addition, it can

prevent repeating of the tracks, use filters, and priority rules. Playlists can be generated manually or

automatically by schedule.

You can launch Playlist Generator Pro from the menu: Playlist -> Playlist Generator Pro. 
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General information and an example of use

A playlist is generated according to a given structure (rotation), which consists of categories.

A category consists of tracks that will be used in the playlist.

Example:

Say, you want to create a eight-hour-long playlist with the following rotation:

§ Top100

§ Station ID

§ Music

§ Station ID

§ Music

§ Station ID

In the example, it plays one Top100 track, then two Music tracks with Station ID after every song, and

then it repeats. There are only three different types of tracks in this rotation. So three categories of

tracks will be created: Station ID, Top100, and Music.

To create a category, click the “+” button below the list of categories. A window with category options

will open:
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  •  On the General tab, enter a Category name (for example, “Music”; this name will be used to display

the category in the list), duration (e.g. one track). 

  •  On the Tracks tab, enter the source of tracks for the Category. It may be a folder, playlist, music

library, or track — whatever better suits your needs. RadioBOSS will select the appropriate number of

tracks from that source.

  •  For the Station ID category, turn on the Ignore all “do not repeat” rules option on the No-

repeat tab. It is recommended to check this check box for jingles, sweepers, station IDs and other non-

music tracks.

  •  Click OK.

  •  Create other categories in a similar fashion.

Once all categories are created, define the rotation. To do that, select a category in the list and click the

right-arrow button (you can also drag-and-drop a category). The category will be added to the Rotation

window. To change the order of categories in the list, use the up-arrow and down-arrow buttons. To

delete a category from the list, use the “–” button. To move categories within the list, drag-and-drop

them using a mouse.

In the example above, the following rotation will be created:

* Top100

* Station ID

* Music

* Station ID
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* Music

* Station ID

In the example, we needed a eight-hour-long playlist, so we checked the Total playlist length check

box and set the corresponding parameter at 8 hours 0 minutes. (If the check box were unchecked, the

generator would go through the Playlist Structure only once, and then the playlist generation would be

finished.)

When the Total playlist length check box is checked (as in the example), the generator will repeat the

pattern (cycling through the Playlist Structure) until the desired duration is reached.

In the end, you should see something like this:

Est. duration - shows the time of one rotation cycle. 

Total playlist length - shows the total time the playlist is set to play.

On the Settings tab, you can set various no-repeat rules to improve the resulting playlist.

To save the Preset for future use, click the Save button in the top of the window. To rename a preset,

right-click its name. You can use the saved Preset, for example, for automatically scheduled generation

of playlists.

To create a playlist, click the Generate button. The Log tab will open, where you can see the generation

progress, errors, and the resulting length.
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To load the playlist into RadioBOSS right away, click the Export to player button.

The Save playlist button saves the created playlist to a file.

To create several playlists at once, click the down arrow next to the Generate button and select

Generate multiple playlists... More about creating several playlists.

See also

Command line interface

Playlist Generator Pro Settings

Categories

4.3.1 Categories

To create a category, click the “+” button under the list of categories: 

The category window will open.

Category Settings:

General

Track sources

Filters

Priority

No-repeat
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4.3.1.1 General

Name - name of the category, the category be shown on the list under this name – for instance, “Music”

Global category - if checked, this category will be accessible in all other presets, otherwise, it will only

be private for this preset. Enabled by default.

Duration - the number of tracks or minutes that will be taken from the category during each rotation

cycle. 

Use all tracks from the source - all source tracks will be used every time.

Use this category only once (do not loop) - this category will be used only once (during the first

rotation cycle).

Outro: add only at the end of the playlist - add the track(s) from the category at the end of the

playlist only. 

4.3.1.2 Track sources

At the top of the window, select category source type: Tracks or Categories. 

Tracks
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Select the tracks for this category. This can be a playlist, a folder, a music database, a set of single

tracks. Several different sources can be used.

You can use special tags (file name templates) in file names that the program will replace with

corresponding values. Please see the file name templates section on the Event page. Use the ?noeval

tag to prevent template being processed by the playlist generator (in this case, template will be

processed upon playlist playback). To enter macro values, select an entry in the Tracks source list,

press "..." button and select "Edit item" option.

Tracks can be selected randomly or in order. In the latter case, tracks in the source are sorted

alphabetically. In case of Random selection, settings on the Priority tab affect how selection will happen.

If there are no priority rules enabled, it will shuffle the list of tracks and try to select each one before

repeating. The Random (fast) option can be used for categories with a large number of tracks. In this

case, the random selection will work a lot faster, but with slightly reduced quality.

Start position - sets the initial track position in the source. This track will be the first to be selected

when the "In order" option is enabled. This function is used for publishing materials that consist of

several parts (such as lectures, for example). The "Advance on each generation" setting increases

the starting position for the next playlist generation (so that the next part is used when a new playlist is

created).
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Categories

When the source type is set to Category, other categories are used as a track source. Several categories

can be added as a source, with different weights. On each track selection, it will select a random

category and get one track from there. Weight determines the probability of a category being selected,

e.g. category with a weight of 2 is two times more likely to be selected than a category with a weight of

1.

Example: 

CategoryA has weight = 1

CategoryB has weight = 2

That means, the CategoryB has twice a chance of being selected for the playlist, compared to the

CategoryA. For example, if 100 tracks are selected, the result have ~34 tracks from CategoryA and ~66

tracks from CategoryB.
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4.3.1.3 Filters

On the “Filters” tab, you can set additional filters for tracks, such as year, rating and track duration. Filter

values work inclusively.

Tags filter

Rules to filter tracks by Tags. In order to pass the filter, a track must match all the defined rules.

Filter by year

For the filter by year, you can use now and prev, which is current and previous year, respectively.

Filter by comments

It is recommended to use the Tags filter instead of the comment filter. The comment filter is an

obsolete feature we keep for backward compatibility. 

Show details 

One or several words are defined in the filter. If any of them is found in a track's comments, the track will

pass the filter. You can also define mandatory words using the REQUIRE keyword. Exclude tracks using

the NOT keyword. Keywords in track tags should be separated with a comma (,) or semicolon (;): slow,

moody, 80s.

For example: bass, synth, REQUIRE 90s, NOT slow - select tracks containing bass or synth in

comments, definitely contain 90s and do not contain slow.
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Filter by genre

One or more genres are defined for track selection. To select several genres, list them through a

comma: pop, rock (in this case, Pop or Rock tracks will also be in the category). Tracks without a genre

are excluded. 

Filter by gender

Filter tracks by the "Gender" field. You can specify multiple options by separating them with a comma.

Filter by language

One or more languages are specified for track selection. To specify multiple languages, they must be

separated by commas.

4.3.1.4 Priority

The “Priorities” tab lets you configure extended track selection rules. Priority represents the odds of a

track being added to the playlist. 

Track priority is calculated automatically and is based on the set rules. Each track has a base priority

of 50, which corresponds to a “standard” chance of being put on the playlist. Values under 50 lower this

chance, and values over 50 increase it. Priority values range from 0 to 100. Thus, 0 translates into a

very low chance of making it to the playlist, while a value of 100 makes a file three or four times more

likely to appear there (compared with the base priority of 50). Priority values below zero exclude the

track completely.
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Priority rules change track priority based on track properties, i.e., playcount, year, last played,

date added, and genre. For instance, for a track that hasn’t been played in a while , you can give it a

better chance of being added to the playlist. This chance can be lowered for unpopular tracks. 

Priority rules based on Tags are processed as an AND operation (a track must contain/not contain all the

selected tags)

Date added / Last played rule: specify the number of days and condition (less than, more than,

equals). For instance, a rule "Date added less than 10" will be applied to tracks that were added to the

Music Library less than 10 days ago (non inclusive). Fractional values are also accepted, e.g. 0.5 means

half of the day - 12 hours.

Playcount rule: you can use the MIN, MAX, and AVG (minimum, maximum and average) values for the
“Playcount” rule. For example, you can set a higher priority for tracks whose number of playbacks is
fewer than AVG (average).

Year rule: you can use the NOW or CURRENT to specify the current year, and PREV or PREVIOUS to
specify the previous year. You can use simple calculations such as: CURRENT-1 - previous year.
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4.3.1.5 No-repeat

The “No-repeat” tab can be used for redefining the global non-repeat settings for an artist, track,

album, and track name, and set additional separation rules (year, genre, language, gender, tags). When

tags is selected, you define what tags not to repeat (it checks each tag separately).

For jingles, station-related information inserts and non-music tracks, we recommend enabling the

“Ignore all "do not repeat" rules” option.

Related topics:

Repeat protection rules
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4.3.1.6 Constraints

This section is used to define the constraints rules. Those rules allow you to set which tracks cannot be

selected one after another. Rules can check tracks by the assigned Tags or general tag fields (Comment,

Language, Genre, and others). 

Skip this category when checking the Constraints rules - when checked, tracks inserted from this

category will be skipped when processing the constraints rules. Typically, this should be enabled for

station IDs and similar items.
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All comparisons are case-insensitive. When using the "More than" or "Less than" options, the comparison

is performed as numbers (invalid number strings are treated as zero).

4.3.2 Settings

To improve the quality of the playlist, you can configure different repeat playback protection rules on the

"Settings" tab:

Do not repeat artist for ... - sets the period of no repetition for a particular artist, in minutes. 

Related artists - allow you to prohibit the playback of songs by related artists. This option is used in

situations where an artists is known under several stage names or when the same artists performs

independently and as part of a band. To configure this function, click the "+" button in the "Related

artists" window, add an artist and click "OK". Once done, open (double-click or right-click on "Edit") the

new artist and enter related artists, one name per line, in the new window.
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Multiple artists - repeat protection for multiple artists listed through a separator. For instance, if the

artist is Metallica feat. Aphaville, the individual artists (Metallica, Alphaville) will not be repeated,

including when they are listed with another artist. E.g. Metallica feat. Michael Jackson will also be

considered as a repeated artist.
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Matching rules (Consider artists identical if their names match for ... %) - do not repeat artists

with similar names. Adjust the accuracy of relatedness calculation. You can test the feature by clicking

the “Test” button, entering some artists and seeing how similar they appear, in percent:

Do not repeat track for... – sets the no-repeat periodicity of a track, in minutes.

Do not repeat album for... – sets the no-repeat periodicity of an album, in minutes.

Only compare albums from the same artist - the "do not repeat album for" rule can only be set for

one artist.

Do not repeat title for – sets the no-repeat periodicity of a track name (for instance, in situations

when different artists’ tracks have the same title). 

Ignore remix info – will ignore remix information included in the track's title. It removes anything that is

written in the parentheses. For instance, "Song name (Remix by DJ)" will be transformed into "Song

name".

Use the Last Played tag- activates protection against repeats using the "Last Played" tag.
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Repeat protection: Take into accounts tracks in the playlist window - factors in the rule for not

repeating tracks that are on the playlist window in RadioBOSS. Tracks after the currently playing track

are checked. Press the "..." button to configure how many tracks to check.

On error, create an empty playlist - creates an empty playlist if an error occurs in the process of

generating a playlist. If this option is turned off, when error occur the categories can be skipped; in case

when there are many errors, the resulting playlist duration can be less that configured. "Error" means

that the playlist generator is unable to find a track that meets all the criteria (repeat protection rules,

filters etc).

Filter non playable tracks - filters out tracks that can't be played (e.g. corrupted tracks, tracks with

zero duration, unsupported file format etc).

Amount of track overlap – consider the duration of crossfades.

Related topics:

Repeat protection rules

4.3.3 Automatic Playlist Generation

This guide will help you automatically generate playlists on schedule using Playlist Generator Pro.

First, create a preset in the Playlist Generator Pro and save it. It is called “Day” in the example. 



Operation 75

Copyright 2025 DJSoft.Net. All rights reserved.

After creating the preset, close Playlist Generator Pro and do the following:

1. Create a new scheduler event in RadioBOSS.

2. Click the Wizard button. Select “Generate a playlist”, and then click “Next.”

In the wizard window below, select the preset. Click “Next” to generate a command and insert it into the

“Filename/Command” field of the event.
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You don’t have to use the Wizard each time. The command to generate a playlist with Playlist Generator

Pro has the following format:

generate preset_name

Substitute preset_name with the preset name you would like to use.

After creating an event, RadioBOSS will automatically generate playlists at the specified time and start

the playback.

If you need to create and save a playlist only, without playback, you need to select the option "Save

generated playlist to a file (do not start playback) and specify a file name. 

4.3.4 Generating multiple playlists

The playlist generator allows you to create several playlists at once. It uses a shared track no-repetition

buffer, which makes it possible to use long no-repetition intervals (e.g. several days). To create multiple

playlists, select the Generate multiple playlists option.
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A window with playlist generation options will appear:



RadioBOSS User Manual78

Copyright 2025 DJSoft.Net. All rights reserved.

To create playlists, select the presets to be used by clicking the "+" button. For each preset, you need to

specify the name of the file it will be saved to. All playlists are saved to a specified folder. 

The "Number of playlists" option defines the number of playlists to be created for each preset on the list.

If the number of playlists is greater than 1, you need to use modifiers in the file name.

File name modifiers:

%n - a number with no leading zeros (1, 2, ... 10, ... 100).

%nn - a number padded with one leading zero (01, 02, ..., 10, 100).

%nnn - a number padded with two leading zeroes (001, 002, ..., 010, 100)

For example, if you run multiple playlist generation with the "Number of playlists" set to 1 and "Start

number" set to 1, you'll have 5 playlists in the D:\Music folder:

D:\Music\playlist_01.m3u8

D:\Music\playlist_02.m3u8

D:\Music\playlist_03.m3u8

D:\Music\playlist_04.m3u8

D:\Music\playlist_05.m3u8

Clicking the arrow next to the Generate button lets you perform some additional actions:

Create event - add an event to RadioBOSS scheduler to create and save playlists.

Copy command line - copy the command line to create and save playlists.

4.3.5 Command Line Interface

Playlist Generator Pro command line parameters

You can use the command line interface to automatically generate playlists and save them to a specified

location. When multiple playlists are generated in one run, they share the same no-repeat buffer, which

means it's possible to create several playlists for extended periods of time with no repeated tracks.

Usage: PlaylistGeneratorPro.exe -preset=PRESET -out=PLAYLIST [-n=N]

Options:

-preset= specifies the preset name (multiple presets can be specified separated by "|").

-out= specifies the file name for saving the generated playlist (use a full path with the extension .m3u8).

Multiple file names, matching the preset number, can be specified separated by "|".

-n= how many playlists to generate (default = 1). If used, the -out option need to contain one of the

modifiers: %n, %nn or %nnn (see below for more information). If a single number is specified, it will

create this number of playlists for each preset specified in the -preset parameter. You can set a specific

number of playlists to create using the "|" separator, e.g. -n=2|6|3 - this will create 2 playlists using

the first preset, 6 playlists using the second preset, and 3 playlists using the third preset.

-s= when using "-n", the -s option sets the starting number for playlist naming. Example: -s=5

Example: generate a playlist using the MyPreset preset and save it to C:\playlist.m3u8

PlaylistGeneratorPro.exe -preset=MyPreset -out=C:\playlist.m3u8
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If the name of a present contains a space, parameters must be encased in quote marks:

PlaylistGeneratorPro.exe "-preset=My Preset" "-out=C:\Folder name\playlist.m3u8"

You can use the run command in the scheduler together with the command line interface to generate

playlists and save them to a specific folder (for example, on a production machine). Unlike automatic

playlist generation, doing that will only save a playlist but will not play it.

Example of such a scheduler event (note: there's no need to specify a full path to

PlaylistGeneratorPro.exe program): 

run PlaylistGeneratorPro.exe -preset=MyPreset -out=C:\playlist.m3u8

 

Generating multiple playlists in one run

File name modifiers when multiple playlists using the same preset are created:

%n - a number with no leading zeros (1, 2, ... 10, ... 100).

%nn - a number padded with one leading zero (01, 02, ..., 10, 100).

%nnn - a number padded with two leading zeroes (001, 002, ..., 010, 100)

Example: 

PlaylistGeneratorPro.exe -preset=MyPreset -out=C:\playlist_%nn.m3u8 -n=11

Warning: If a command is executed in a .bat file, the percent sign must be written twice:

PlaylistGeneratorPro.exe -preset=MyPreset -out=C:\playlist_%%nn.m3u8 -n=11

This command will generate 11 playlists and save them under the names:

C:\playlist_00.m3u8

C:\playlist_01.m3u8

C:\playlist_02.m3u8

...

C:\playlist_10.m3u8

Example: create a different number of playlists using different presets 

PlaylistGeneratorPro.exe "-preset=Weekday|Weekend" -n=5|2 "-out=D:

\Playlists\Weekday%n.m3u8|Weekend%n.m3u8"

This command creates 5 playlists using the Weekday preset, and 2 playlists using the Weekend preset.

Generating multiple playlists using multiple presets in one run

The following example creates 3 playlists using the Morning, Day and Evening presets and saving them

to D:\Playlists\Morning.m3u8, D:\Playlists\Day.m3u8, and D:\Playlists\Evening.m3u8 respectively. This

allows to prepare playlists in advance and then start them when needed.

Note: when playlists are generated in batch, they share the same no-repeat buffer, which means it's

possible to create several playlists for extended periods of time with no repeated tracks.
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Example:

PlaylistGeneratorPro.exe "-preset=Morning|Day|Evening" "-out=D:

\Playlists\Morning.m3u8|Day.m3u8|Evening.m3u8"

You can specify the full path for the first playlist only; in this case, all playlists will be saved to the same

folder. You can specify the full path for all playlists.

4.4 Advertisement Scheduler

You can use the Ad Scheduler to manage advertisements, that is, to automatically create and schedule

advertisement blocks.

To launch it, click Tools -> Ads Scheduler

How to use

First-time setup:

1) On the first launch, open the Settings window. (The application will prompt you to do that, just click

Yes.)

2) Set the working folder for saving generated playlists and events.

3) On the Ad blocks tab, select the hours and minutes for placing ads. (You can change this setting

later.)

4) Click OK.

Operation:

· In the main window, click the Add button to add tracks. The tracks will appear in the list. You can also

drag the files from Windows folders to the application window, in this case, each file will be added as a

separate entry. Ads are edited in the Ads Parameters window.

· To add a track to a block, put a check mark in the corresponding grid cell by right-clicking or double-

clicking it, or pressing the space bar. A number will appear that indicated number of ads in the block. 

· After filling the grid for each track, click the Create playlists and events button. Playlist files for

each ad block and scheduler events to start those playlists at specified times will be created. Events

can be automatically added to the RadioBOSS Scheduler.

· Important! For Start and End settings to work, you must set up an automatic advertisement playlist

and events update. 

· Multiple profiles can be used for different sets of the advertisements (commercial, social, political,

etc, each with own settings of intro/outro, blocks and other options).

The color of ads in the list indicates their status: 

Black – normal state;

Red – the track was not found on the disk;

Gray – the track finished running on the specified date; 

Blue – running the track has been planned for a future date; 

Light-gray – the track is disabled.
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When you select a cell in a gird, on the right it will display the ads for the selected block. Ads of the same

type following each other will be marked in bold.

You can save and load grid presets to re-use the same grid for new tracks. To do it, click the Edit button

below the “Selected Ad properties” grid.

You can access the media plan, that is, view all ad blocks or selected ones only. To do it, click the Ads

overview button and select the necessary view mode.

You can set the length of ad blocks as desired. Click “Block setup...” –> “Sweepers...”.

The Test All Blocks button allows you to check all blocks. The following parameters are checked:

whether there are 2 or more clips of the same type in a row, whether a block exceeds the maximum

duration (specified in settings).

When using multiple profiles, the Create playlists and events button, as well as adsupdate

scheduler command will create playlists and events for all profiles.
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4.4.1 Automatically update ads playlists and events

In order to take into account the settings for the start and end of when commercials are played, you must

update the advertising playlists and events from time to time. This can (and should) be done

automatically. To do this, click "Create playlists and events", and enable the option "Create event

to automatically update ads" in the new window. Choose an update period - every hour or once a

day. If you need to run and shoot ads every hour on the nose, they must be updated once an hour.

You can also create an event manually by adding it to the scheduler using the adsupdate command or

adsremote command if using remote ads management.

4.4.2 Remote ads management

The Ad Scheduler is able to export ads, playlists and events to a remote RadioBOSS installation.

To use the remote ads management, you'll need to enable API access on the remote RadioBOSS

installation and set a password.

To export your ads from the Ad Scheduler, click the 'Create playlists and events' button.



Operation 83

Copyright 2025 DJSoft.Net. All rights reserved.

Enable the Remote option and enter the connection details:

RadioBOSS API address - enter the IP address of the computer on which RadioBOSS is installed. 

Enter the port and the password that were set when the API was enabled.

It is recommended to keep 'Export audio tracks' enabled.

Click the Run button to export your adverts, events and playlists to a remote computer.

To update events and playlists automatically, schedule an event with the adsremote command. See

also: Automatically update ads playlists and events.
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4.4.3 Advert parameters

Active - Enable/disable the ad track.

Start - Set the start date and time (inclusive) for the ad track.

End - Set the end date and time (inclusive) for the ad track.

Priority - Set the priority of the ad track on the scale of 1 to 9. The priority defines the position of the

track in a block  (1 closer to start; 9 closer to end).

Type - Set the type of the ad track. The type is used for showing warnings in case two or more tracks of

the same type are placed side-by-side (or example, two pizza commercials in a row).

Tracks - assigning alternate tracks to commercials. Alternate ad tracks are used when creating blocks.

When you add the ad track to a block, the ad track is selected (main or one of the alternate ones).

Display group - Select a group to display track in the list.

Background color - Change background color in the ads list for this item

Comment -  Write a comment, note for a ad track. 
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4.4.4 Settings

To open settings window Ads Scheduler in menu click Settings -> Settings...

Settings:

General

Event properties

Ad Blocks

Misc
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4.4.4.1 General

Working directory - select the folder where created playlists and events will be saved.

Pack all tracks into a container - pack all tracks in the ad block into a container.

Generate playlists for empty blocks - create playlists for blocks that do not have ads.

For empty blocks you can Include intro, Include outro, Include sweeper.

Extend priority range - allows to extend ads priority range from the default 1..9 to 1..99.

Grid - show number of ads in each cell - instead of a checkmark, show the number of ads in each

block in the grid.

Save playlists as - select the format of the saved playlist. Preferably use m3u8 (default).

Playlist filename template - specify file template for created playlists.
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Instance name - name Ads Scheduler instance, it will be displayed in the window title bar.

Profile name for reports - profile name that will be displayed in the generated ads reports.

4.4.4.2 Event properties

Ad scheduler creates tasks with specified settings.

Event properties are identical to the settings in the scheduler.
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4.4.4.3 Ad Blocks

In the Ads Blocks section you can set the time (up to the minute) when you want to launch the ads. The

selected blocks will appear in the main window of the ads scheduler in a grid, where each ads can be

placed in each block.

You can also Set block intro, Set block outro, Sweepers and Separators between ads.

Set block intro, Set block outro: set intro and outro for the advertising block. A intro is a track that

plays at the beginning of an advertising block, and a outro plays at the end of the advertising block. When

selecting Track list or Playlist you choose one track from a folder or playlist. Track button: select a

specific track. 
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Sweepers: configure additions for padding the advertising block out to the required length.

Separators: insert separators between ads. One ad will be selected randomly from the folder.
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4.4.4.4 Misc

Warn when block is longer than (0=no warning) - specify block duration, upon expiration of which

a warning will be issued. Zero - do not show warning.

4.5 Tools

4.5.1 Music Library

The library is used for quick search and to help generate a new playlist in the Playlist Generator. 

The library offers tools to help manage a database. For example: The Verify command scans the

database for any entries or file(s) that have been deleted from the hard disk, and removes the invalid

entries automatically. With the built-in audio player you can preview tracks. 

To create a music library:

On the top menu bar click Music library > Open Music Library

This opens the Music library window. 
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Now you can add music tracks: add single files or folders.

You can perform various actions using the Tools menu.

Process tracks – normalize tracks, detect BPM, remove silence, detect Mix and Mix Start points. More

about track processing.

Check music tracks – checks audio files for errors, and then displays a list of bad tracks. This option

also allows you to check the track's tags. 

Schedule automatic library update – creates a task in RadioBOSS to scan the specified folders and

add audio files to the database. 

User defined fields

The music library allows the definition of up to five custom user fields. Custom fields appear in tag editors

(Track Tool and bulk tag editor in the music library) and can also be used in the Report Generator.
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Related topics:

Playlist Generator

Quick search

4.5.1.1 Process Tracks

To process music tracks, open Music Library, in the menu click Tools -> Process music tracks.

The "Process tracks" window will open. Please note: Trim Silence, Mix, and Mix Start detections are

level-based, and normalized level is taken into account when detecting those. If you change target

normalization level, or tracks were not normalized before - after normalization you should re-run Trim

silence, Mix and Mix scan to update them based on a new sound level (the "Skip tracks with [...] set"

options must be unchecked in all blocks).

When detecting Mix point, the value of "Mix point" set in the Crossfading settings for music, is used as a

minimum value (in case detected value is lower).

At the top of the window, you select what tracks to process: all tracks, or only selected tracks. Please

note that only tracks that present in the list are processed: if you used filters, only filtered tracks will be

processed, not the entire library.

Important! Mix Start requires Start mark to be set (run Trim Silence processing, or set it manually

with Track Tool).
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Related topics:

Track Tool

4.5.2 Report Generator

RadioBOSS has a tool to generate ready-to-print reports of what was played. 

To open report generator click Tools -> Report Generator

Report Generator: 
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In this window you select report period (start and end dates), report type and report fields: title, artist,

album, year, genre, comment, playcount, length, etc.

Report type:

Playcount - each track will appear in report once but will show how many times it was played

List - will list all played tracks

The report can be sorted by set criteria. To apply sorting, select the Sort by (Artist, title, album, year...)

and Direction (Ascending or descending) fields.

Set the fields you want to see in report: move fields from Available to Selected list. Start hour starts with

the 00 minute; end hour is at 59 minute (inclusive). For example, to generate report for 8:00:00 AM to

8:59:59 AM, select both start and end hours at 8 AM.

After all set, click the Preview button.

A window where you can print or save report will appear:
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4.5.2.1 Command line

Report Generator supports command line to allow automatically creating the reports. It can be called

using the run scheduler command.

Command line format

ReportViewer.exe --create=Filename|Format|DateFrom|DateTo|Type|Fields

Parameters

Filename - report file name with no extension

Format - CSV or PDF

DateFrom - starting report date in ISO format (YYYY-MM-DD, e.g. 2023-12-30)

DateTo - end report date in ISO format

Type - List or Playcount

Fields (optional) - list of fields to include in the report (a list of numbers, comma separated); if not

included, default field set it used

Fields

0 - Title

1 - Artist

2 - Album

3 - Year

4 - Genre

5 - Comment

6 - Playcount

7 - Length

8 - Start date/time
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9 - Start date

10 - Start time

11 - Listeners

12 - Filename

13 - Total length

14 - Language

15 - Publisher

16 - Album artist

17 - Composer

18 - Copyright

End of the month (for DateTo parameter)

Specify 00 (two zeroes) as the day to specify end of the month, for instance: 2023-01-00 will convert to

2023-01-31. This is useful when the month is not known in advance, e.g. when using file name templates

(see examples below).

Example command line

C:\Program Files\RadioBOSS\ReportViewer.exe --create=C:\report|PDF|2023-01-01|2023-01-31|List

Example command line specifying fields (title, artist, playcount)

C:\Program Files\RadioBOSS\ReportViewer.exe --create=C:\report|PDF|2023-01-01|2023-01-31|List|

0,1,6

Example using the "run" scheduler command (no need to specify full path to .exe file in this case)

run ReportViewer.exe --create=C:\report|PDF|2023-01-01|2023-01-31|List

Example using the "run" scheduler command with file name templates to create monthly reports

automatically

run ReportViewer.exe --create=C:\report-?yyyy-?mm|PDF|?yyyy-?mm-01|?yyyy-?mm-00|List

4.5.3 Track Tool

Track Tool used to set individual track parameters: start, end, intro, outro and others.

To start the Track Tool, right-click a track in the playlist and select Track Tool.

To zoom, use the Zoom+ and Zoom- buttons or mouse wheel. Hold Ctrl key to zoom faster.
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Start - sets the beginning of a track. The playback will start from that point.

End - end of the track.

Intro, Outro - intro and outro portions of the track. This is used in Voice Tracking.

Fade In, Mix, Fade Out - set the individual crossfading parameters.

Mix Start - adjust track mixing position to allow it start earlier in the mix, typically Mix Start set after

the quiet start part of the track. During playback, player will match Mix position of the playing track, and

Mix Start position of the following track. Important! Mix Start requires Start mark to be set. 

Hook In, Hook Out - setting a place to cut the track for use in the Teasers.

Voice Ins - setting voiceover location.

Playback level - set track playback level.

* Start, End, Mix, Mix start and Playback Level can be auto-detected using the Process Tracks tool

in Music Library. 

To show/hide Tag Editor click the dark gray bar on the left.
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To stop the playback, press the space bar. You can zoom in and out using the mouse wheel while the Ctrl

key is pressed

and held. The zoom level can also be changed from the context menu that

appears after right-clicking on the graph.

If the option Disable song is active, the playlist generator or track list will not use this track when

creating playlists.

The Set start/end dates button is used to set the track's start and end dates. If set, then a track will

be used only during the time specified. Typical usage for this feature is to make specific songs appear in

the playlists only at certain dates (for instance, New year songs). For this feature to work, both start

and end dates have to be set! 

The Disable song and Start/end dates are considered only when Playlist Generator or Track List are

used.

4.5.4 Segue Editor

Segue Editor is called from the playlist: right-click a track which crossfade parameters you want to edit,

and select Segue Editor (to edit 2 tracks) or Segue Editor 3 (to edit 3 tracks).

A window opens: 

Example: Segue Editor for 2 tracks

Red line shows track volume level. Use mouse to move tracks and square points. 

Custom crossfade parameters are saved in the playlist. When you open and close RadioBOSS, the

parameters will remain. To save the playlist to a file in RadioBOSS top menus click File->Save (or Save

As...).
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4.6 Microphone

RadioBOSS lets you use a microphone any time during audio playback.

Note: If you have a hardware mixer board, you probably don’t need the software MIC feature, as you

can connect the microphone directly to the mixer.

How to use the microphone

First of all, make sure that a proper device is selected for the MIC button: microphone settings.

Press the  

 

button in the bottom-right corner to turn on microphone.

Right-click the MIC button to find additional options for microphone: configure DSP, enable/disable

various options.

Play next track after MIC is off - when you turn off microphone, next track will start playing (this

option does nothing if Sidechain is enabled for microphone). If the playlist is stopped, and "Stop after

current track" option is not enabled, next track will not start.

Related topic:

Microphone settings

4.7 Linear input

RadioBOSS lets you add a line input to a playlist. Line input settings can be configured via Options on the

Input tab.

Line input is useful for retransmitting a signal received via the sound card’s input (e.g. a satellite feed).

To use the line input, select Playlist -> Add Line Input... in the top menu bar.

A window will open, where you can set the duration (that is, for how long you want the Line.In to be

played). Optionally you can enter a broadcast title.  
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This menu item will be hidden if no device is selected for Line.In in Settings.

“Line.In” plays just like an ordinary file in the playlist. Crossfading and most other effects are applied to it

as well.

4.8 File Types

RadioBOSS allows you to set up file types for particular types of tracks. For each file type, you can specify

the color in the playlist, crossfade parameters, and amplifying level for playback (-20 to +20 dB). Files

that do not belong to any file type are treated as "Music" for crossfading.

Assigning tracks to file types possible in different ways:

1. Folder based. Specify the folder in File type folder field. If the folder is specified, all tracks in this

folder (and sub-folders) are considered to be tracks of the given type.

2. Use identifier. An identifier is a word or a sequence of characters that assigns a file to a particular

type. Identifier should be included in the tag information or filename: RadioBOSS looks for an identifier in
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the tag area (artist/title) or the filename if a file has no tags. It's not recommended to use short

identifiers which can appear as a part of regular track's titles - for instance, if your identifier is "id", it can

be found in the track called "The Beatles - Everybody's Got Something to Hide". The solution would be to

use "id:" (add a colon before and/or after the identifier) or choose another identifier. 

Identifiers for special playlist item types

Network stream :// (or any part of the address, for example, domain name)

Playlist comment .comment

Hour marker .hourmarker

Automatic time announcement saytime

Command .command

Text to speech tts=

Teaser teaser=

Line input line.in or line2.in or .in

Container container=

3. You can use the Track Tool to assign a track for a particular file type. You can set the file type for

multiple tracks at the same time via Music Library.

For example: The first group is named “Commercial”. Its identifier is “Commercial”, the color is set to

red, and the amplifying level is set to +5dB. In this case, all tracks containing the identifier "Commercial"

in tags (title/artist) or filename will be displayed red in the playlist and played louder than other tracks.

The file will be mixed according to the crossfade parameters configured for the “Commercial” group in

the Crossfades window.
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File type options:

Name File type name

Identifier File type identifier

Look for identifier in RadioBOSS looks for an identifier in the tag area (artist/title)

or the filename if a file has no tags

File Type folder Define file type folder. All tracks found in this folder (and in

sub-folders) will be considered tracks of a given type.

Color in playlist Coloring of the tracks of this type in the playlist. Click the box

to change the colors

Amp Change the level to amplify or lower the level when a track of

this type is played

Include tracks of this type in

report

Controls whether tracks of this type should be included in the

report

Treat as a Voice track If checked, tracks of this type will be treated as Voice Tracks
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Treat as a music track If checked, tracks of this type will be treated as music. This is

used in features like Teaser or Time Stretch where the file

types can be excluded from processing. When this option is

checked, tracks of this type will not be excluded as file types.

Do not send title to the server This option allows you to not send the track's name to the

server. Enabling this option also prevents nowplaying

notifications.

Use custom title format Specify a custom broadcasting title format for this file type.

Please see this page for details.

Use bed for playback A bed can be set, which will play in the background

Skip after scheduled tracks After the event is completed, the selected file type in the

playback queue will not be played back

Skip after file types

Skip before file types

Do not play before or after selected file types

Do not update playcount Playcount will not be increased and last played tag will not be

set for tracks of this file type

 

To set up a new file type, follow these steps:

1. On the top menu bar, select Settings > Options...

2. Click File Types.

3. Enter the name of a new file type into the Name field.

4. Enter the identifier of a file type into the Identifier field.

5. Select background and font colors.

6. Move the Amp slider to set the amplification level if needed.

7. Click OK.

Related topic:

RadioBOSS. Quick start.

4.9 Crossfading

Crossfade allows you to define the mix (overlap) point, and fade in/out parameters for music and other

files. To open this window, select Settings –> Crossfades in the menu.
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Controls and options:

Fade in
Time interval in the beginning of a track for the volume to go up. When a track is

started, the volume will go linearly from 0 to 100% during that time.

Mix

point

The moment before the end of a track when the next track starts playing, overlapping

with the current track.

Trigger

mix at

The “Trigger mix at" setting is based on a sound level (default setting is –14dB). The

“Mix point” option must be turned on too.

If the “Trigger mix at” option is turned on, the “Mix point” value (2.5 seconds by default)

controls the minimum overlap duration.  

Fade out Time interval in the end of a track for the volume to go down.
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Start

fading

out on

mix

The fade out will be started together with Mix. If the “Fade out” option is turned on, the

"fade out" value defines the fade out duration.

File type

selector

Selects the file type for editing the crossfade settings.

Override

previous

track

mix

Overrides the previous track's mix point to control how many tracks overlap. This is

useful for commercials and jingles in order to avoid long overlap with the preceding

music track. 

File

types

section

Define crossfades for each of the File types.

Important! For Containers, custom fading settings for file types are not applied.

More information:

Using different types of files

Fading settings

4.10 Normalizing tracks

You can normalize music tracks in RadioBOSS in order to make them the same volume level. RadioBOSS

uses EBU R128 standard to determine loudness. Normalizing does not change or re-encode music files.

Any level corrections are reversible and do not reduce sound quality.

To normalize tracks, use the Tools->Process tracks menu command in Music Library to batch process

music tracks. You can also use the Auto button near the level slider in Track Tool to normalize a single

track. It is also possible to automatically build a library and normalize tracks using the makelibrary

scheduler command.

4.11 Stream and podcast playback

To insert a stream or podcast into the playlist, in the menu click Playlist -> Add URL...

A window will open where you can enter the stream URL and set the duration:
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Check the Podcast checkbox if a URL points to a podcast: in this case, RadioBOSS will select the newest

stream from the feed and play it. When the podcast checkbox is checked, the URL has to point to an

XML podcast feed. 

When the Stream duration is set to 0 (zero), RadioBOSS will play a stream until its end (or until

something else is started in the playlist). If the duration is non-zero, RadioBOSS will play a stream for a

specified amount of time, restarting the stream in case of any errors, e.g. connection failure. Note!

Streams with no duration specified (0) will not be restarted in case of an error.

4.12 Cart wall

Cart wall is used for instant on-demand playback of various audio files. Click on a cell to start/stop

playback. Click on a playing item while holding the Shift key to restart it from the beginning.

To add cart wall: click the "+" button in the Playlist section and select "Cart wall":

The 5x5 grid is created:
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To assign tracks: right-click the cell and click "Edit...". 

In the window that appears, select the file you want to play as well as its color and display name (the

name is displayed in the center of cell). Click OK. 

You can specify line.in or line2.in as the file name to playback the line input. Set file name to stopall to

make the cart button stop all playing carts. Cart wall also supports scheduler file name templates.
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In the settings, you can enable the Playlist Volume option to set the volume of the playlist during the

playback of the Cart Wall item. If the option is not set, the general setting from the Fades section (Cart

wall section) is used.

To fill cells, you can drag and drop tracks from Explorer. You can also drag and drop tracks between
cells.
After the setup is done, you can play tracks when you need: simply click on the corresponding cell. In the
bottom-left corner the remaining playback time will be shown. To stop playback, click the cell again.
Right-click on a cell to edit it or enable loop.

Carts may be played on another audio device: playback settings.

Right-click a cart wall tab to save or load the cart wall grid: 

The No UAC option allows editing the cart wall for all users, even without the "Cart wall" rights.

You can now change the size of the cart-machine's grid. To do that, right-click on the tab and select
"Change grid size..." command from the menu. You will see a new window for entering the necessary
number of rows and columns. 
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If you reduce the number of cells, the ones that do not fit into the resized grid will be removed.

You can assign a hot key for the cart wall as follows: Right-click the cart wall tab, select “Hot key
modifier” in the context menu, and set a desired option.



Operation 111

Copyright 2025 DJSoft.Net. All rights reserved.

When Ctrl or Shift is set as a hot key modifier: to play a track, press (and release) Ctrl (or Shift), and
then press the key corresponding to the necessary track. For example, if you want to listen to a track
under the digit 2, press Ctrl, and then press the “2” key. If the track is under the letter M, press Ctrl, and
then press the “M” key. When Caps Lock is set as a hot key modifier, simply press CapsLock+A (or any
other key) to play the corresponding cart wall item.
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To stop the playback, press the same keys again. 

You can create a few carts on the cart wall. Pressing Ctrl+2 will create two carts, and pressing Ctrl+3 will
create three ones.

More information:

Playback

4.13 Using Track list

Track List appears as one track in the playlist. When launched, one file is played from the list, selected

either randomly or in order. This is an easy way to create random playlists.
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To add a track list, follow the steps below:

1. On the top menu bar select Playlist > Add Track List...

2. Select a source of the tracks, click Select playlist... or Select folder....

In case of a folder, you can also check the "Recurse subfolders" to include tracks that are in subfolders.

3. Choose a track selection method, set one of the options:

· Random - tracks will be selected in Random order. RadioBOSS will try avoid repeating tracks unless all

the tracks are played from the source.

· In order - tracks will be selected one by one in order (when using folder source, the tracks are sorted

alphabetically by filename).

· Series - tracks will be selected one by one in order, but the position in the list will not advance

automatically: the same track will be chosen until the list position is advanced. To advance the position,

a scheduled event needs to be used: click the Create event... button to add the event. 

The event to advance the position can be added any time later on: 

Option 1. Add a scheduled event and use the Scheduler wizard: select Play one track from a

playlist or folder, Next button, Play one track from a playlist or folder (Track List),

Next, select the same source folder, and make sure that "Recurse subfolders" is in the same

state as it was when the series was added. Click the Create event button.

Option 2. Right-click the Track List item in the playlist, select Tools and then select

Rename/edit. Click the Create event button.

Repeat protection
Click the Repeat Protection button to enable repeat protection options for Track List.
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The repeat protection settings are global and applied to all Track List items used in RadioBOSS. Track List

can be set to ignore the no-repeat rules: the Ignore repeat protection rules checkbox (useful for

jingles, station IDs and similar items where repeat protection should not be used).

More information:

Generating a playlist

Repeat protection rules

4.14 Using Tags

A Tag in RadioBOSS is something you can assign to a track to help categorize, search tracks or use a

filter when creating a playlist.
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Use the Music Library to batch assign or remove tags: right-click menu, Add tags and Remove tags

command. Tags can also be edited using the Track Tool or the track information panel in the main

window.
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The "Add tag" window enables to create new tags and use the existing tags. To quickly select one tag

and close the window, double-click it.

Removing or renaming a tag does not remove or rename it for the tracks where the tag was used. In

order to remove or rename a tag, first remove it from all tracks using the Music Library, then, if renaming

it, create a new tag and assign it to tracks. You can clean up tag list for music tracks by using the Tools-

>Tags cleanup menu command in the Music Library.

More information:

Music library

Generating a playlist

4.15 Voice Tracking

RadioBOSS supports voice tracking, namely recording and playback.

To record a voice track and insert it into a playlist, use the corresponding commands in the Playlist

menu:
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If you click the “Record voice track...” menu item, the Voice track recording tool will open: 

The tool uses the same input device as set for the MIC button.

To start recording, click the Record button. Once finished, click Stop. To listen to the track recorded,

click Play. The Pre-listen sound card is used for playback. To edit a voice track, use the Edit commands.

To save a voice track, click the Save button. Save all voice tracks in the Voice Track folder (you can

change its location via Settings -> General).

To insert a voice track into the playlist, click the Insert voice track menu item. All voice tracks appear

in italics  in the playlist.

Voice tracks are played automatically in the intro/outro portions of the tracks. You can set the intro and

outro for tracks using the Track Tool.

The picture below shows the general idea on how voice tracks are played:

Red is the Outro part of Track1, and Green is the Intro part of Track2. For short voice tracks (shorter

than Intro + Outro), a voice track will be played closer to the end of the Intro of Track2.
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Some voice track-related playback parameters can be configured via Settings -> Playback -> Voice

Tracking.

If you don't want to set and use Outro points, and only need to play voice tracks based on Intro, in

Settings, General press the "Advanced configuration" button and set "Voice Tracking - Ignore Outro point

and always play voice tracks up to Intro" option to "True".

A short note about what Intro and Outro are:

Intro is an opening instrumental part of the track, before the singer starts singing.

Outro is a conclusion of the track, usually an instrumental solo.

4.16 Voiceovers

Voiceovers allow to insert a voice at the indicated position in the music track. Voiceovers are configured

using Track Tool - set the Voice Ins mark and edit voiceover parameters (press the "..." button). You

can prelisten the voiceover by right-clicking the "..." button.

Voiceovers can be enabled or disabled (for example, they can be disabled for nighttime broadcasts) using

the scheduler commands: enablevo, disablevo.

Voiceover parameters window

Parameters

Voice insert - choose a file or folder containing voiceovers. If you choose a folder, a random file will be

selected from it every time.

Position - sets the insertion position. Start - the voiceover will begin at the selected place. End - the

voiceover will end at the selected place.

Probability - set the probability of voiceover playback.

Playback level - playback level of the voice insert.



Operation 119

Copyright 2025 DJSoft.Net. All rights reserved.

Do not play after - set voiceover expiration date.

For a track with a voiceover, the voiceover is shown in pink in the "On Air" window.

4.17 Auto Intro

The Auto Intro feature allows to automatically insert jingles before music tracks. 

To use the Auto Intro, select Tools > Auto Intro on the top menu bar.

The Auto Intro window will open. It shows the list of defined Auto Intro rules. 

Click the Add button to add new rule. Use the Edit button to edit the selected rule. The Up and Down

buttons are used to move rules in the list.

By default, the rules are prioritized based on their order in the list: the rules closer to the top have higher

priority. If two or more rules can be applied to a music track, the topmost rule will be used. You can

change priority using the Rule check order option.

Intro tracks are started and ended with a small fade in/fade out (you can configure it in Settings, General,

Advanced Configuration). The underlying music track is attenuated in accordance with Voice Track

settings in the Fading area.
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The rule parameters window:

The window allows to set the following parameters

Name - the rule name in the list. The name is also used in the autointro scheduler command to enable

and disable rules.

Intro tracks - set the list of jingles to insert. It can be a single file, a playlist or a folder. In the case of a

playlist or a folder, it will select one random jingle (subfolders not included).

Probability - set the probability of inserting a jingle. 100% - always jingle, 33% - on average, insert one

jingle for every three tracks and so on.
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Condition - if Condition is set, the jingle will only be inserted for the music tracks that match the criteria.

For instance, condition can be used to apply auto intro for tracks of a certain genre or for tracks from a

specific artist. When checking a condition, the letter case is not taken into account. Range condition is

defined as starting and ending value, e.g. 1990-1999. Duration condition is set in seconds. If a second

condition block is set, they must both be met.

Must contain tags - use Auto Intro only for the tracks with specified tags (all or any). 

Skip file types - do not apply Auto Intro for tracks that belong to file types.

Skip after file types - do apply Auto Intro if previously played track belongs to one of the selected file

types.

Position on track - set the auto intro jingle position on the music track. Start at and End at set the

position type: where jingle should be started, or where it should end. Then the time value is set, in

seconds, or it can be a special value: Intro or Fade In. For instance, if the position is set to End at:

Fade In the jingle will end its playback at the time when the underlying music track finishes fading in. If

position is set to End at: 3.5 the jingle will end 3.5 seconds after the start of the music track.

Cooldown - after a rule is applied, it will no longer be used again until the cooldown period passes.

4.18 Teasers

Teasers - automatically created teasers from tracks. The start jingles, the transition between the tracks,

and the end are defined in teaser properties. For music files, you can use the hook marks to determine

the part of the track to be included in the teaser (the Hook In and Hook Out are assigned using the Track

Tool, Hook duration must be less than 21 seconds). Alternatively, RadioBOSS can automatically determine

the location where teasers should be made in the track (AutoHook). A source of tracks can be a folder on

disk, or the tracks that are going to be played next in a playlist. When the next tracks are announced, the

teasers work only if the "Shuffle" mode is turned off and only if regular tracks are used: such special

elements as the Track List, Internet streams, commands, etc., are ignored.

To add a teaser to a playlist, in the menu click Playlist -> Add teaser.

To reproduce the teaser through the scheduler in the wizard, you must select Automatic announcement -

Teaser .

To create a file type for teaser, use the teaser= identifier.

General structure of the teaser

o Start jingle

o Teaser of track 1

o Transition

o Teaser of track 2

o Transition

o Teaser of track 3

o Transition

o Teaser of track 4
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o Ending jingle

The beginning, end, and transition jingles are optional.

A crossfade is applied between the teaser elements. Its parameters can be set in the teaser settings

window (the Settings button in the teaser window).

The Start, Transition, and End define the start, transition, and end jingles, respectively. You can select

a folder (in this case, a random file will be selected; subfolders not included) or a file. If you do not want

any of the jingles, then leave the field empty. 

Tracks - select the source of tracks:

o Coming up next - specify the number of tracks that come after the track that is currently playing in

the playlist. Max tracks to look ahead - specify the number of tracks that can be used to make

teasers.

o Tracks from a folder - select tracks from a folder (subfolders not included).

Track count - determine the number of tracks in the teaser: this number of tracks will be selected from

the source folder.
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Shuffle tracks - random tracks will be selected from the source.

AutoHook for tracks without hook points - this option is used for tracks without the Hook In and

Hook Out positions; the teaser locations will be determined automatically. 

o Duration - the length of the automatic hooks created by AutoHook.

Settings - button that brings up the teaser settings window.

Transitions - this is used to set the options for crossfade transition between teaser elements. These

settings have similar functionality to the crossfade settings.

Track exceptions - tracks that are excluded from the teaser. This option allows you to exclude very long

and very short tracks as well as file types (for example, news, advertising, etc.).

4.19 Relaying

RadioBOSS can relay other network streams during specified time intervals. It supports the automatic

transition back to the playlist if the relayed stream becomes unavailable and returns to relaying when the

stream is available again.

Use the scheduler to start and stop relaying: when adding an event, click the Wizard button, select

Relay and then select the action: start or stop relaying. Instead of using a wizard, you can enter the

commands manually: relaystart URL (URL - the address of a stream to relay) or relaystart 1 (to relay

Input 1) to start relaying, relaystop to stop.

Use the settings window to change general relaying configuration.

4.20 Record your broadcast

This function can be used both for archiving your broadcasts and preparing prerecorded shows. With

RadioBOSS, recording broadcasts is extremely easy. 
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To use this feature, select the Stream Archive item in the Tools menu.

Alternatively, click the Stream Archive button on the toolbar. 

A window will appear, where you can configure all necessary settings for recording a program. You can

start or stop recording automatically, by adding the streamarchive command to the scheduler.
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4.21 Render playlist to a file

RadioBOSS supports rendering a playlist to a single audio file. This allows creating mixes that can be

replayed later or uploaded to hosting platforms. The resulting mix takes into account all usual playback

settings - crossfading, levels, etc. 

To create a mix, please use the Tools - Render playlist to file menu command. In the window, select

the audio format and press the Render button. After pressing the button, a window will appear where

you need to select where to save the file. When the process is complete, you will see Done entry in the

log.



RadioBOSS User Manual126

Copyright 2025 DJSoft.Net. All rights reserved.

4.22 Remote Control API

You can control RadioBOSS remotely by using its Remote Control API.

Enable and configure this feature via the Settings window: Configure Remote Control API. 

HTTP remote control API reference

Note: When generating a request string, use one of the URL Encoding functions for parameters. For

example, use urlencode (http://www.php.net/manual/en/function.urlencode.php) for PHP. Requests

should be sent in UTF8 encoding.

I. Executing a command. You can use the same commands as in the scheduler. Here’s the list of

commands available: Scheduler commands

Commands that can not be used from the API: getrandomplaylist, getfile, playrequestedsong

Syntax:

http://IP:Port/?pass=PASSWORD&cmd=COMMAND

or, when connecting with remote API user's credentials:

http://IP:Port/?user=USERNAME&pass=PASSWORD&cmd=COMMAND

(substitute “COMMAND”, “USERNAME” and “PASSWORD” accordingly)

Example 1: Play the next track (command: next)

http://127.0.0.1:9001/?pass=WxPe2JXh&cmd=next

http://www.php.net/manual/en/function.urlencode.php


Operation 127

Copyright 2025 DJSoft.Net. All rights reserved.

Example 2: Play the first track in the playlist (command: “play 1”)

http://127.0.0.1:9001/?pass=WxPe2JXh&cmd=play%201

II. Performing an action

Syntax: 

http://IP:Port/?pass=PASSWORD&action=ACTION

or, when connecting with remote API user's credentials:

http://IP:Port/?user=USERNAME&pass=PASSWORD&action=ACTION

(substitute “ACTION”, “USERNAME” and “PASSWORD” accordingly)

Possible ACTION values:

playbacki

nfo

get

playback

informatio

n

Returns an XML containing the current and next track information, and playback position,

state and some other information.

Example

http://127.0.0.1:9001/?pass=WxPe2JXh&action=playbackinfo

An example of data returned: show
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<?xml version="1.0" encoding="utf-8"?>
<Info>

<CurrentTrack>

<TRACK ARTIST="50 Cent" TITLE="I&#39;ll Still Kill feat Akon   Track 4"

ALBUM="Curtis" YEAR="2007" GENRE="Unknown Genre"

COMMENT="http://www.689.ru/" FILENAME="D:\disko\Artist\50 cent\50 Cent -

I&#39;ll Still Kill feat Akon Track 4.mp3" DURATION="00:00" 

PLAYCOUNT="26" LASTPLAYED="2019-02-02 04:26:57" INTRO="0.00" OUTRO="0.00"

LANGUAGE="" F1="" F2="" F3="" F4="" F5="" CASTTITLE="" LISTENERS="0" />

</CurrentTrack>

<Playback pos="0" len="-11" state="stop" playlistpos="0" />

<Options repeat_list="0" shuffle="0" />

<Features scheduler="0" />

<Streaming listeners="0" />

<Relay On="0" Active="0"/>

<PrevTrack>

<TRACK ARTIST="50 Cent" TITLE="Outta Control" ALBUM="Massacre" YEAR=""

GENRE="" COMMENT="" FILENAME="D:\disko\Artist\50 cent\50_Cent_-_08_-

_Outta_Control.mp3" DURATION="03:21"  PLAYCOUNT="0" LASTPLAYED=""

INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1="" F2="" F3="" F4="" F5=""

CASTTITLE="" />
</PrevTrack>

<NextTrack>

<TRACK ARTIST="50 cent" TITLE="01_Intro" ALBUM="Get rich or die

tryin&#39;" YEAR="" GENRE="" COMMENT="" FILENAME="D:\disko\Artist\50

cent\50 cent - 01_Intro.mp3" DURATION="00:06"  PLAYCOUNT="34"

LASTPLAYED="2019-05-25 12:35:40" INTRO="0.00" OUTRO="0.00" LANGUAGE=""

F1="" F2="" F3="" F4="" F5="" CASTTITLE="50 cent - 01_Intro" />

</NextTrack>

</Info>

inserttra

ck

insert a

track into

the playlist

Parameters

"filename" — local file name

"pos" — a position in the playlist where track should be inserted (1 ... N).

Other possible values:

 -1: insert into the end of the playlist

 -2: insert after the playing track

 -3: insert after scheduled tracks

"streamingtitle" — set broadcasting title for the inserted item

Example

Insert the track “D:\music\track.mp3”

http://127.0.0.1:9001/?pass=WxPe2JXh&action=inserttrack&filename=D%3A%5Cmusic%

5Ctrack.mp3&pos=-2

Returns OK if successful

library

download

a music

Parameters

"filename" — music library name

Returns: music library contents

http://127.0.0.1:9001/?pass=WxPe2JXh&action=inserttrack&filename=D%3A%5Cmusic%5Ctrack.mp3&pos=-2
http://127.0.0.1:9001/?pass=WxPe2JXh&action=inserttrack&filename=D%3A%5Cmusic%5Ctrack.mp3&pos=-2


Operation 129

Copyright 2025 DJSoft.Net. All rights reserved.

library file

(xml) Example

http://127.0.0.1:9001/?pass=WxPe2JXh&action=library&filename=Base

library_e

dit

edit music

library

Parameters

"type" — request type:

o delete - delete music track from a music library

"library" — music library name

"fn" — path to music file

Returns OK if successful

Example

http://127.0.0.1:9001/?

pass=WxPe2JXh&action=library_edit&type=delete&library=Base&fn=C%3A%5CMusic%

5CTrack01.mp3

trackart

work

download

artwork

for the

current

track

Returns: artwork for the currently playing track (or nothing if there is no artwork)

nexttrac

kartwork

download

artwork

for the

next track

Returns: artwork for the next track (or nothing if there is no artwork)

setnexttr

ack

set the

next track

Parameters

"pos" — the position of a track in the playlist, which will be selected as a next track (1 ...

N)

Example

Set the first track in the playlist to be played next.

http://127.0.0.1:9001/?pass=WxPe2JXh&action=setnexttrack&pos=1

Returns OK if successful

delete

delete a

track from

playlist

Parameters

"pos" — the position of a track in the playlist, which will be deleted (1 ... N). Multiple

values can be specified, comma separated, e.g. 1,3,10.

Example

Delete second track in the playlist

http://127.0.0.1:9001/?pass=WxPe2JXh&action=library_edit&type=delete&library=Base&fn=C%3A%5CMusic%5CTrack01.mp3
http://127.0.0.1:9001/?pass=WxPe2JXh&action=library_edit&type=delete&library=Base&fn=C%3A%5CMusic%5CTrack01.mp3
http://127.0.0.1:9001/?pass=WxPe2JXh&action=library_edit&type=delete&library=Base&fn=C%3A%5CMusic%5CTrack01.mp3
http://127.0.0.1:9001/?pass=WxPe2JXh&action=setnexttrack&pos=1
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http://127.0.0.1:9001/?pass=WxPe2JXh&action=delete&pos=2

Returns OK if successful

move

move a

track to

another

position in

the playlist

Parameters

"pos1" — original track position

"pos2" — new track position

Returns OK if successful

mic

turn

microphon

e on and

off or

query

microphon

e status

Parameters

"on" - 0 to turn microphone off, 1 to turn on. If the parameter is omitted, returns

microphone status, if parameter presents, returns OK if successful.

0 - off

1 - on

Example (turn microphone on):

http://127.0.0.1:9001/?pass=WxPe2JXh&action=mic&on=1

Example (query status):

http://127.0.0.1:9001/?pass=WxPe2JXh&action=mic

getplaylis

t

get playlist

contents

deprecate

d, please

use

getplaylis

t2 instead

Returns: an XML containing the playlist contents. This function reads tag information and

can be slow for large playlists.

Parameters:

(optional) "from", "to" - if set, get tracks from position from to position to (inclusive),

instead of retrieving the whole playlist.

An example of data returned: show

<?xml version="1.0" encoding="utf-8"?>
<Playlist>

    <TRACK ARTIST="Metallica" TITLE="Battery" ALBUM="Master Of Puppets"

YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:\Metallica\Master of

Puppets\01 Battery.m4a" DURATION="05:12"  

PLAYCOUNT="1" LASTPLAYED="2018-01-16 20:20:30" INTRO="0.00" OUTRO="0.00"

LANGUAGE="" F1="" F2="" F3="" F4="" F5="" />
    <TRACK ARTIST="Metallica" TITLE="Master Of Puppets" ALBUM="Master Of

Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:

\Metallica\Master of Puppets\02 Master Of Puppets.m4a" DURATION="08:35"  

PLAYCOUNT="1" LASTPLAYED="2018-01-16 20:20:38" INTRO="0.00" OUTRO="0.00"

LANGUAGE="" F1="" F2="" F3="" F4="" F5="" />
    <TRACK ARTIST="Metallica" TITLE="The Thing That Should Not Be"

ALBUM="Master Of Puppets" YEAR="1986" GENRE="Metal" COMMENT=""

FILENAME="D:\Metallica\Master of Puppets\03 The Thing That Should Not

Be.m4a" DURATION="06:36"  

PLAYCOUNT="0" LASTPLAYED="" INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1=""

F2="" F3="" F4="" F5="" />
</Playlist>

http://127.0.0.1:9001/?pass=WxPe2JXh&action=delete&pos=2
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getplaylis

t2

get playlist

contents

Returns: an XML containing the playlist contents. 

Parameters

(optional) "cnt" - max number of tracks to return, 0 = return all tracks 

An example of data returned: show

<?xml version="1.0" encoding="utf-8"?>
<Playlist COUNT="3" TS="251736906">

    <TRACK STARTTIME="" CASTTITLE="Aerosmith - Amazing" DURATION="05:56"

FILENAME="D:\Artist\Aerosmith\Aerosmith - Amazing.mp3" RATING="0"

PLAYCOUNT="0" INTRO="00:00" OUTRO="00:00" BPM="" PLAYLISTINDEX="0"

INDEX="1" FT_IDX="-1" ITEMTYPE="TRACK" PQUEUE="0" ARTIST="Aerosmith"

TITLE="Amazing" ALBUM="" YEAR="" GENRE="" COMMENT="" LASTPLAYED=""

LANGUAGE="" F1="" F2="" F3="" F4="" F5="" />
    <TRACK STARTTIME="" CASTTITLE="Aerosmith - Crazy" DURATION="05:16"

FILENAME="D:\Artist\Aerosmith\Aerosmith - Crazy.mp3" RATING="0"

PLAYCOUNT="0" INTRO="00:00" OUTRO="00:00" BPM="" PLAYLISTINDEX="1"

INDEX="2" FT_IDX="-1" ITEMTYPE="TRACK" PQUEUE="0" ARTIST="Aerosmith"

TITLE="Crazy" ALBUM="Get A Grip" YEAR="1993" GENRE="Rock" COMMENT="FAN

style" LASTPLAYED="" LANGUAGE="" F1="" F2="" F3="" F4="" F5="" />

    <TRACK STARTTIME="" CASTTITLE="Aerosmith - Cryin&#39;"

DURATION="05:09" FILENAME="D:\Artist\Aerosmith\Aerosmith - Cryin&#39;.mp3"

 RATING="0" PLAYCOUNT="0" INTRO="00:00" OUTRO="00:00" BPM=""

PLAYLISTINDEX="2" INDEX="3" FT_IDX="-1" ITEMTYPE="TRACK" PQUEUE="0"

ARTIST="Aerosmith" TITLE="Cryin&#39;" ALBUM="" YEAR="" GENRE="" COMMENT=""

 LASTPLAYED="" LANGUAGE="" F1="" F2="" F3="" F4="" F5="" />
</Playlist>

trackinfo

get track

informatio

n

Parameters

"pos" — the position of a track in the playlist

Example

http://127.0.0.1:9001/?pass=WxPe2JXh&action=trackinfo&pos=2

An example of data returned: show

<?xml version="1.0" encoding="utf-8"?>
<Info>

    <Track>

        <TRACK ARTIST="Metallica" TITLE="Master Of Puppets" ALBUM="Master

Of Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:

\Metallica\Master of Puppets\02 Master Of Puppets.m4a" DURATION="08:35" 

PLAYCOUNT="1" LASTPLAYED="2018-01-16 20:20:38" INTRO="0.00" OUTRO="0.00"

LANGUAGE="" F1="" F2="" F3="" F4="" F5="" />
    </Track>

</Info>

songrequ

est

add song

request

Parameters

"filename" - file name of a requested song (full path)

"message" - optional, message from a user who requested a song

To manually view the list of requested songs, in the menu click View->Song Requests...
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To automatically play the requested songs use the playrequestedsong scheduler

command.

Returns OK if successful

songrequ

estclear

clear the

requested

songs list

Clears the requested songs list.

Returns OK if successful

songrequ

estlist

get

requested

songs list

Returns: an XML with requested songs list. Show example

<?xml version="1.0" encoding="utf-8"?>
<SongRequest>

    <Request filename="C:\Music\Track01.mp3" message="The message"

played="False" age="101" />

    <Request filename="C:\Music\Track08.mp3" message="Another message"

played="True" age="340" />

</SongRequest>

encoders

tatus

get status

of

broadcasti

ng

encoders

Returns: an XML containing with encoder status information. Show example

<?xml version="1.0" encoding="utf-8"?>
<Encoders>

    <Encoder index="0" status="idle" error="" name="96k" listeners="0" />

    <Encoder index="1" status="off" error="" name="Icecast 128k"

listeners="0" />

    <Encoder index="2" status="active" error="" name="localhost:8000"

listeners="0" />

</Encoders>

streamar

chivestat

us

get stream

archive

status

Returns Stream Archive status

0 - off

1 - on
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schedule

control

scheduled

events

Parameters

"type" - the request type, one of: 

o list - list events (returns all events in XML format)

o delete - delete an event

o run - run event

o add - add new event

o update - edit event

o state - turn scheduler on or off or retrieve scheduler state

"event" - XML event data (when type is "update" or "add")

"id" - event ID, you get the event ID when you perform "list" query (used when type is

"delete", "run", or "update")

"set" - on  or off  (when type is "state"), if parameter is omitted - returns current

scheduler state

"skipnext" - set to 1 to skip the scheduled event launch (when type is "run").

Returns

· for delete, run, add, update requests: OK if successful

· for state request: on - schedule enabled, off - scheduler disabled

Event list XML example
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<?xml version="1.0" encoding="utf-8"?>
<Events>

<item EnabledEvent="True" UseDate="False" EveryYear="False" Imm="False"

Above="False" FileName="generate [pro] 1h" MuteLev="50" DelPrev="True"

DoNotRunIfStopped="False" bRepeat="True" nRepeatPer="60"

DoNotMarkAsScheduled="False" nRepeat="1" RepeatLimit="False"

TimeToStart="" Shuffle="False" PausePlaylist="False" UseWeeks="False"

Enqueue="False" DelTaskAction="0" DelTaskUseDate="False"

TaskName="Playlist" ClearMainPlaylist="False" UseDaysOfWeek="True"

Hours="000000000000000000000000" Minutes="0" Seconds="0" TimeType="0"

TaskNameAsTitle="False" IntTimeToStart="2147483647" ItemImageIndex="63"

FontColor="-16777208" BackColor="-16777211" GroupName="" DTMFOn="False"

DTMFString="" DTMFOnly="False" DTMFExitOn="False" DTMFExitString=""

MaxTimeWaitOn="False" MaxTimeWaitSec="0" MaxTimeWaitAction="0"

UseFillers="False" FillersSource="" FillersRecurse="True"

FillerMaxAmount="120" Id="DKCODACFWSIKHULWXDUL" Days="1111111"

Weeks="00000" Time="2018-02-17 00:00:00" DelTaskTime="2018-02-17

00:00:00" />

<item EnabledEvent="True" UseDate="False" EveryYear="False" Imm="False"

Above="True" FileName="http://127.0.0.1:8092/live" MuteLev="50"

DelPrev="True" DoNotRunIfStopped="False" bRepeat="False" nRepeatPer="10"

DoNotMarkAsScheduled="False" nRepeat="1" RepeatLimit="False"

TimeToStart="" Shuffle="False" PausePlaylist="False" UseWeeks="False"

Enqueue="False" DelTaskAction="0" DelTaskUseDate="False" TaskName=""

ClearMainPlaylist="False" UseDaysOfWeek="True"

Hours="000000000000000000000000" Minutes="0" Seconds="0" TimeType="0"

TaskNameAsTitle="False" IntTimeToStart="2147483647" ItemImageIndex="56"

FontColor="-16777208" BackColor="-16777211" GroupName="" DTMFOn="False"

DTMFString="" DTMFOnly="False" DTMFExitOn="False" DTMFExitString=""

MaxTimeWaitOn="False" MaxTimeWaitSec="0" MaxTimeWaitAction="0"

UseFillers="False" FillersSource="" FillersRecurse="True"

FillerMaxAmount="120" Id="BBTHCRXFCOENENGPGOFG" Days="1111111"

Weeks="00000" Time="2018-03-13 00:00:00" DelTaskTime="2018-03-13

00:00:00" />

</Events>

Explanation of some XML event attributes

Imm - Run scheduled launch without waiting for current track to finish

bRepeat - Repeat every

Enqueue - Queue after the scheduled tracks

DelPrev - Replace scheduled tracks

Above - Overlay playback

MuteLev - Playlist level when overlay event is playing

PausePlaylist - Pause the playlist while overlay event is playing

getlastpl

ayed

get list of

last played

tracks

Parameters

"filter" = 1 - (optional) exclude tracks whose titles have not been sent to the server

Returns: an XML containing information about recently played tracks. Show example
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<?xml version="1.0" encoding="utf-8"?>
<LastPlayed>

    <TRACK ARTIST="Metallica" TITLE="Master Of Puppets" ALBUM="Master Of

Puppets" YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:

\Metallica\Master of Puppets\02 Master Of Puppets.m4a" DURATION="08:35" 

PLAYCOUNT="1" LASTPLAYED="2018-01-16 20:20:38" INTRO="0.00" OUTRO="0.00"

LANGUAGE="" F1="" F2="" F3="" F4="" F5="" STARTTIME="2018-01-16 20:20:38"

CASTTITLE="Metallica - Master Of Puppets" />

    <TRACK ARTIST="Metallica" TITLE="Battery" ALBUM="Master Of Puppets"

YEAR="1986" GENRE="Metal" COMMENT="" FILENAME="D:\Metallica\Master of

Puppets\01 Battery.m4a" DURATION="05:12"  PLAYCOUNT="1" LASTPLAYED="2018-

01-16 20:20:30" INTRO="0.00" OUTRO="0.00" LANGUAGE="" F1="" F2="" F3=""

F4="" F5="" STARTTIME="2018-01-16 20:20:30" CASTTITLE="Metallica -

Battery" />

</LastPlayed>

readtag

read track

tag

informatio

n

Parameters

"fn" - file name

"artwork" (optional) - 1 to include artwork in response (base64-encoded)

Example

http://127.0.0.1:9001/?pass=WxPe2JXh&action=readtag&fn=D:\Metallica\Metallica%20-%

20Darkness.mp3&artwork=1

An example of data returned: show

<?xml version="1.0" encoding="utf-8"?>
<TagInfo>

    <File FN="D:\Metallica\Metallica - Darkness.mp3" Duration="446028"

Artist="Metallica" Title="Darkness" Album="" Year="" Genre="" Comment=""

BPM="" Rating="0" Playcount="0" LastPlayed="2018-01-16 20:20:30"

UserField1="" UserField2="" UserField3="" UserField4="" UserField5=""
TypeIdentifier="Commercial" TagsList="" Intro="-1" Outro="-1" FadeIn="-1"

FadeOut="-1" Mix="561" Level="2.3" Start="166" End="260043"

PlayedHistory="2021-06-03 19:50:49 2021-06-03 19:50:49"

Artwork_Base64="/9j/4AAQSkZJRgABAQEASABIAAD..." HookIn="-1" HookOut="-

1" />

</TagInfo>

writetag

write track

tag

informatio

n

Parameters

"fn" - file name

"data" - new tag data in XML format (same as returned by readtag).

Return value 

OK if successful

Error with error message text on error

writeart

work

update

artwork

for a track

Parameters

"fn" - file name

"artwork" - artwork data, base-64 encoded
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Request must be made using POST method, content type application/x-www-form-

urlencoded

Request example using PHP: show

$artwork_fn = 'C:\path\to\artwork.jpg';
$fn = 'C:\path\to\track.mp3';
$api_path = 'http://localhost:9000';
$password = 'api_password';

$artwork = file_get_contents($artwork_fn);
$artwork_64 = base64_encode($artwork);
$curl = curl_init();
curl_setopt_array($curl, [
 CURLOPT_URL => $api_path,
 CURLOPT_RETURNTRANSFER => true,
 CURLOPT_HTTP_VERSION => CURL_HTTP_VERSION_1_1,
 CURLOPT_CUSTOMREQUEST => 'POST',
 CURLOPT_POSTFIELDS => http_build_query(['action'=>'writeartwork', 'pass'=>$password, 'fn'=>$fn, 'artwork'=>$artwork_64]),
 CURLOPT_HTTPHEADER => ['cache-control: no-cache', 'content-type: application/x-www-form-urlencoded']
]);
curl_exec($curl);

Return value

OK if successful

Error with error message text on error

setcastti

tle

set new

title on

streaming

servers

Parameters

"title" - new cast title

Return value 

OK if successful

status Returns: an XML containing RadioBOSS version and uptime in seconds.

An example of data returned: show

<?xml version="1.0" encoding="utf-8"?>
<Status>

<Player version="5.9.0.7" uptime="486470" />

</Status>

getencod

er

get

encoder

configurati

on

Parameters

"id" - encoder ID (0..N), 0 - first encoder in the list

Returns: XML data with encoder configuration

An example of data returned: show
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<?xml version="1.0" encoding="utf-8"?>
<Encoder Server="c13.radioboss.fm:8000/live" Password="df4f5k1b"

Public="False" Format="0" Bitrate="128" Encoding="0" SampleRate="44100"

Channels="2" StatPassword="" DisplayName="" Enabled="False"

UseStatsRelay="False"></Encoder>

setencod

er

edit

encoder

configurati

on

Parameters

"id" - encoder ID (0..N), 0 - first encoder in the list, -1 - add new encoder

"data" - encoder data in XML format (as returned by getencoder).

Return value

OK if successful

deleteen

coder

delete

encoder

Parameters

"id" - encoder ID (0..N), 0 - first encoder in the list

Return value

OK if successful

4.23 User Account Management

The "User Access Control" function of RadioBOSS enables you to control users' access to various

program features, such as playlist editing; adding, changing and removing tabs; playback control; effects

modification, etc. This feature is only available in RadioBOSS Advanced edition. 

The "Lock" function: when this option is enabled, you will see a window that will lock the program until

the password is entered or another user logs in:
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Every option of the Users function are easy to configure. User settings can be changed only after

entering the admin password.

Enabling the "Administrator (full access)" option grants all available permissions. 

Default user - this setting selects the user with whose permissions the program will launch.

If you have enabled the "Users must login to use RadioBOSS", you will need to enter the password of

one of the users to use RadioBOSS.

ATTENTION! Please remember that if you lose or forget the admin password, you may lose access to the

program. The first user on the list always has admin rights. If there are other users with admin rights,

they cannot remove the first admin, change or view his/her password. 

4.24 Additional information storage

Additional information consists of various track properties that RadioBOSS uses in its operation. This

information includes: playback count (playcount), last played date, additional track properties (gender,

language, BPM, etc), user defined tag fields and some other information.

There are several ways to store the additional information:

· Tag (APEv2)

· Database (SQLite) - the default

· Database (MySQL) - requires MySQL (from version 3.21 up to version 8.4) or MariaDB (from version

5.5 up to version 10.6); recommended to use MariaDB.

· File

· File (subfolder)

All methods have their pros and cons. No configuration is required for APEv2, SQLite, or File storage

methods. MySQL option requires a MySQL or MariaDB server, the connection details need to be entered
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into RadioBOSS. The storage method is configured in the settings. Switching between the storage

methods is always possible, please see this guide for details.

Storing information in an APEv2 tag

Pros

o The information is persistent, as it's stored in the music file: when you copy or move a file, the

information is preserved

o No additional files are created

Cons

o The music file is modified each time it's played (to update playcount and other data)

o Not all music files support APEv2, in this case NTFS alternate data streams are used to save the

data. Currently NTFS strerams are used for FLAC, WAV, DSF, DFF files.

o Requires write access to music files which is not always possible or desired, especially when network

storage is used

Storing information in SQLite or MySQL database

Pros

o Music tracks are not modified as information is stored externally

o Can be used with read-only music folders, e.g. network folders, read-only NAS access

o Faster operation: loading information from the database is much faster than reading the file tag

o MySQL database allows working with music library from different computers. Important! File paths

have to be the same on all computers. E.g. if a network drive with music is mounted, it needs to be

mounted under the same drive letter on all computers.

o SQLite: you can use a shared (among all RadioBOSS installations on one computer) database or a

dedicated database for each installation. Press the Settings button in the General area to configure it.

The default is to use a shared database.

Cons

o The information is linked to the music track via its file path, if the file is moved or renamed, the

information will be lost. 

o MySQL database: file names, including path, must not exceed 767 characters.

Notes

o MySQL: if you get an error about "caching_sha2_password" please execute the following SQL

command in MySQL Command Line Client (change root to your user name, and password to the

user's password):

§ ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'password';

Storing information in File / File (subfolder)

Pros

o Easy to backup or copy/move to another computer. The information is stored in an additional file

with .rbdata extension in the same location as the music file (i.e. for "Track01.mp3", additional file
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will be named as "Track01.mp3.rbdata"). When storage is set to "File (subfolder)", all .rbdata

files are stored in the .rbdata subfolder.

o No database is required and music files are not modified

Cons

o An additional file (about 0.5 KB) is created for each music file

4.24.1 Changing additional information storage

In order to change where additional information is located, if you want to transfer data from old location

to the new, please follow the following steps: 

1. Open Music Library, add music tracks for which you want to perform information storage change (you

can open the existing library). 

2. Select all tracks in the list.

3. In the menu, click Tools->Convert additional info command.

4. Important! Ensure that "From" is correct - it should show the current storage. 

5. Change "To" to the new storage location.

6. Press the Start button and wait until it completes. Close Music Library and all other RadioBOSS

modules (e.g. Playlist Generator).

7. Open RadioBOSS, in Settings, General change Additional information storage location to the

new storage. 

8. Restart RadioBOSS.

4.25 Additional features

4.25.1 Editing tags

RadioBOSS has a built-in audio tag editor. It supports ID3v1, ID3v2, Xiph, MP4, WMA, and other tag

formats. You can see the tag editor below the playlist window.

If the tag editor is hidden, do either of the following:

* Press Ctrl+I

* Click the small (i) icon below the playlist

* In the menu, click View -> Track Information

Xiph (Vorbis) Comment (used for FLAC, OGG and OPUS files) supports multiple Artist entries, in this case,

RadioBOSS will display all artists separated by a comma. 

Please note! If tag editing has been started, track information is not updated, until changes are saved or

canceled (the buttons to save or cancel changes are in the bottom right corner).
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If there is no information about a track, you can enter the information manually. Just right-click on the

information panel and select "Extract artist/title from filename". To save a tag, press enter or click the

Save button in the bottom-right corner.
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More information:

Playlist window

4.25.2 Playback queue

The playback order in the playlist can be changed using the Playback Queue feature. It allows you to

modify the playback order without the need to relocate the tracks in the playlist.

· To add a track to the playback queue right-click a track in the playlist and select Add to playback

queue.

· To remove a track from the queue, right-click a track and select Remove from playback queue (this

command is only visible for the tracks that are in the playback queue).

· View and playback queue: in RadioBOSS top menu bar click Tools - Playback queue...

Tracks that are added to the queue are marked with the order number in brackets.
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Playback queue edit window:

4.25.3 Hour markers

In order to enable Hour Markers right-click the playlist tab and check the "Show hour separation

markers" option. 
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Hour markers will be automatically inserted when a track is started to play, or "Calculate start time"

feature is used (right-click a track in the playlist). You can change how markers look in the playlist in the

File Type settings. 

4.25.4 Automatic time announcements

RadioBOSS can automatically “say” the current time.

To add a time announcement, use the menu: Playlist -> Add time announcement.
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A window will open, prompting you to select a folder with voice files. The folder should contain 24 sound

files for hours and 60 files for minutes.

File naming convention:

· Hour files. Each hour file must have the letter “h” and a two-digit number in the file name. For

example, the file “hr_05.mp3” should say “it’s 5”; this file will be followed by a minute file. For exact

hours, hour files with the letter “o” in the name are used. For example, the file hr_05o.mp3 should say

“it’s 5 o’clock.” (Minutes are not used for exact hours.)

· Minute files. Each minute file must have the letter “m” and a two-digit number in the file name. For

example, the file “m_56.mp3” should say “fifty-six.”

You can download sample voice files from our website: http://www.djsoft.net/enu/download.htm 

You can use Scheduler to start announcements: Click the Wizard button, select “Automatic

announcement,” and follow the instructions.

4.25.5 Automatic Weather Announcements

Updating weather data for your city

To update the weather data, use the scheduled event with the weather command, for example:

weather New York, US

weather Sydney, AU

You can also include the state name in the request i.e.: weather Independence, KS, US

(it is recommended to set this event to start every day one or two times to get the actual weather data)

Weather data is retrieved using the OpenWeatherMap service: http://openweathermap.org/

Weather data is available in variables:

Today weather data

?temp temperature (degrees Celsius)

?temp_f temperature (degrees Fahrenheit)

?wind_speed wind speed (meters per second)

?wind_speed_m wind speed (miles per hour)

?wind_speed_km wind speed (kilometers per hour)

?wind_name wind description in English (e.g. "Light Breeze")

?humidity humidity (percentage)

?weather_text weather text (e.g. "Mostly sunny", "Cloudy")

http://www.djsoft.net/enu/download.htm
http://openweathermap.org/
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Weather data for tomorrow (the meaning for variables is the same as for today's weather)

?temp_tom

?temp_tom_f

?wind_speed_tom

?wind_speed_tom_m

?wind_speed_tom_km

?wind_name_tom

?humidity_tom

?weather_text_tom

Automatic weather announcement using Text-to-Speech (to add TTS, in the top menu click

Playlist->Extra->Add Text-To-Speech) 

Phrase example:

Temperature today is ?temp degrees Celsius wind speed is ?wind_speed metres per second ?wind_name

humidity is ?humidity percent. Tomorrow ?temp_tom degrees Celcius ?wind_speed_tom metres per

second ?wind_name_tom  humidity is ?humidity_tom percent.

If using built-in voices in Windows, better results are achieved if using Windows 8 or newer.

Automatic weather announcements using pre-recorded files with temperature and humidity

Humidity and temperature files should be named to contain the numeric value, examples.

"TMP29.mp3" - temperature file saying "29 degrees Celsius".

"TMP-10.mp3" - "minus 10 degrees Celsius"

"HUM3.mp3" - "humidity is 3 percent"

Create a playlist with appropriate track sequence, for instance, 3 tracks:

1. Weather intro

2. Temperature today (add one of the temperature files into the playlist)

3. Humidity today (add one of the humidity files into the playlist)
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Save this playlist to a file, e.g. weather.m3u8

Open the playlist in a text editor (you can use the Notepad tab in RadioBOSS to edit the text), the file

should look like this:

#EXTM3U

#EXTINF:5,INTRO

C:\Weather\WeatherToday.MP3

#EXTINF:2,TMP7

C:\Weather\Temp\TMP7.MP3

#EXTINF:2,HUM5

C:\WeatherAnn\Hum\HUM5.MP3

Change the numeric values to variables and save the file:

#EXTM3U

#EXTINF:5,INTRO

C:\Weather\WeatherToday.MP3

#EXTINF:2,TMP007

C:\Weather\Temp\TMP?temp.MP3

#EXTINF:2,HUM005

C:\WeatherAnn\Hum\HUM?humidity.MP3

Schedule this playlist to say the automatic weather announcement - on playback, RadioBOSS will

substitute variables with the appropriate values, e.g. ?temp will become "20" and file name C:

\Weather\Temp\TMP?temp.MP3 will be converted to C:\Weather\Temp\TMP20.MP3

4.25.6 Text to speech

The Voice Synthesizer (text-to-speech) allows you to create automatic announcements that will be read

by the program. You can specify the text to be read by the program or specify the path to the file with the

text. The file or text can contain XML tags according to Speech API: https://msdn.microsoft.com/en-

us/library/ms717077(v=vs.85).aspx

In the synthesizer settings, you can select the voice and the reading speed. It is recommended to choose

the voice according to the text language. Additional voices can be installed through the Windows Control

Panel.

https://msdn.microsoft.com/en-us/library/ms717077(v=vs.85).aspx
https://msdn.microsoft.com/en-us/library/ms717077(v=vs.85).aspx
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The text can contain variables, such as weather data and current date/time

%M - month

%D - day

%dw - day of the week

%h - hour (24-hour format)

%hp - hour (12-hour format)

%m - minutes

%s - second

4.25.7 Song request system

RadioBOSS supports automatic song requests. This allows placing song requests automatically via a web

site and play them automatically.

To configure the song request system please use the following:

· songrequest, songrequestclear, songrequestlist remote control API commands to control the

requests: add song requests and clear the requested songs list.

· songrequestclear scheduler command.

· library remote API command to get the contents of the music library.

· Song Request window view the current song requests and manually insert songs into the playlist. To

open the window, in the main menu click Tools->Song Requests (or press Ctrl+Y).

· playrequestedsong scheduler command to automatically play the requested songs.

Song request demo script:

https://www.djsoft.net/community/threads/web-site-song-request-demo-script.5168/

https://www.djsoft.net/community/threads/web-site-song-request-demo-script.5168/
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4.25.8 Converting to other formats

RadioBOSS has a built-in audio converter designed to help converting files to other audio formats and rip

audio CD disks.

To convert a file to a new format, follow the steps below:

1. In the Playlist window right-click a file.

2. In the right-click menu select Tools -> Convert... 
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The Converter window appears. Now it is necessary to configure the output settings, including the

output folder and codec. The output folder is a directory on the hard disk drive where converted tracks

are saved and stored.
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3. Select the output folder and codec.

The Codec menu lets the user select the codec with a desired bitrate.

Now it is necessary to save the selected settings.

4. Click OK

The encoding process will start. The user can see the progress bar that shows the encoding process.

Once encoding is over, the encoded file can be found in the selected output folder.
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More information:

Enabling plugins

4.25.9 DSP manager

RadioBOSS lets you use VST and WinAmp DSP plugins (dsp_*.dll), except ones that change the speed of

a stream. You can also use an integrated DSP (e.g. Equalizer or Compressor).

To open the DSP manager, select the FX tab on the control panel:

To add a DSP, click the “+” button. To remove a DSP, click the “–” button. To change DSP parameters,

use the configuration button .

To move DSP up/down, use the up-arrow/down-arrow button. DSPs are applied from top to bottom.

If you click the “+” button, all available DSP effects will be shown: 
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Check the Winamp DSP plug-ins and/or VST plug-ins check boxes if you want to use these plugins. To

open the folder containing Winamp DSP plugins for RadioBOSS, click “Plugin folders...” 

Select a plugin and click OK. The plugin will be added to the DSP chain:

To turn DSP effects on/off, check/uncheck them in the list.

To install a WinAmp plugin, follow these steps:

1. Download and install the plugin.
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2. Open the plugin installation folder (usually “C:\Program files\Winamp\Plugins”) and copy the plugin-

related files from there to RadioBOSS’s Winamp plugins folder (“<RadioBOSS_Dir>\Plugins”).

3. After installing the plugins, check the Winamp plug-ins check box on the Plugins tab. All detected

Winamp plugins should appear on the list.

Select the plugin that you want to start, and click the OK button.

4.25.10 DTMF tone generator

The DTMF tone generator in RadioBOSS allows to insert DTMF tones to the audio stream. Standard

DTMF tones are supported: 0 - 9, A, B, C, D, # and *.

To insert DTMF into the playlist, in the top menu click Playlist -> Extra -> Add DTMF tone generator.

Enter the DTMF sequence, e.g. "76AC" and click OK. The special track will be added to the playlist, when

played, it will produce the DTMF sequence.

To create a scheduled event that will play the DTMF tone: create a scheduled event, and use the

dtmf=sequence command, e.g. dtmf=76AC. 

4.25.11 Virtual Sound Cards

RadioBOSS allows you to use one or several virtual sound cards (the number of cards is unlimited).

Virtual cards are integrated into the program and require no separate installation. You can add, delete

and enable/disable them in RadioBOSS playback and recording settings.

What is a virtual sound card and what do I need it for?

Virtual cards help redirect sound from one program to another. For instance, you can put a Skype call on

air or redirect sound from a satellite receiver or FM tuner to a program. Each virtual card is a paired

input/output: what enters the output (for example, the card is selected as a playback device in some

program) can be sent to the input (for example, by selecting a corresponding device as a linear input in

RadioBOSS).

Virtual cards are provided by VB-Audio Software (www.vb-cable.com).

The VB-CABLE is donationware (all participations are welcome).

4.25.12 Title format variables

The variables that can be used in title format settings or when using notifications:

%artist - song artist (from the tag)

%title - song title (from the tag)

%casttitle - formatted track title for broadcasting (Notifications only; we recommend using it to send

the current track title)

%album - album name (from the tag)

%year - year (from the tag)

http://www.vb-cable.com
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%comment - comment (from the tag)

%lyrics - song lyrics (from the tag)

%albumartist - album artist (from the tag)

%composer - composer (from the tag)

%publisher - publisher (from the tag)

%copyright - copyright (from the tag)

%genre - song genre (from the tag)

%len - song duration (mm:ss)

%seconds - song duration in seconds

%startsec - song playback start position (seconds)

%endsec - song playback end position (seconds)

%playbackpos - playback position (mm:ss)

%playbackpossec - playback posiiton in seconds

%filename - song file name without path

%filename_ext - song file name with extension, without path

%filetype - file type of the playing track

%path - full file path

%playcount - play counter

%listeners - listener number (currently connected listeners)

%showname  -  name of the current program or show (set using the command set %

showname=TEXT)

%bpm - playing track BPM

%rating - playing track rating (0..10)

%yyyy or %yy, %mm or %m, %dd or %d - current date

%hh or %h, %nn, %ss, %ampm - current time; if %ampm presents, the hour is displayed in 12 hour

format, and %ampm is changed to AM or PM. %hp - hour in 12-hour format

%nextsong - next song title (as shown in the playlist)

%xmldata - current and (if enabled for the nowplaying file) next song information in XML form

(Notifications only)

XML data example 
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<?xml version="1.0" encoding="utf-8"?>

<PLAYER name="RadioBOSS" version="7.0.8.0">

<TRACK ARTIST="Amy Steele" TITLE="The Wolves (Lenzman Remix)" ALBUM="UKF Summer Drum

&amp; Bass Vol. 2" YEAR="" GENRE="" COMMENT="" FILENAME="C:\Muisic\Test\Amy Steele 

The Wolves (Lenzman Remix).mp3" DURATION="05:46"  STARTED="2024-11-18 11:43:28"

PLAYCOUNT="1" LASTPLAYED="2024-11-18 11:43:27" INTRO="0.00" OUTRO="0.00" LANGUAGE=""

RATING="0" BPM="" TAGS="" PUBLISHER="" ALBUMARTIST="Various Artists" COMPOSER=""

COPYRIGHT="" TRACKNUMBER="12" F1="" F2="" F3="" F4="" F5="" CASTTITLE="Amy Steele -

The Wolves (Lenzman Remix)" LISTENERS="0" LYRICS="" />

<NEXTTRACK><TRACK ARTIST="Apex feat. Ayah Marar" TITLE="Space Between Us" ALBUM=""

YEAR="" GENRE="Other" COMMENT="0" FILENAME="C:\Muisic\Test\Apex feat. Ayah Marar -

Space Between Us.mp3" DURATION="06:46"  STARTED="2024-11-18 11:43:28" PLAYCOUNT="0"

LASTPLAYED="" INTRO="0.00" OUTRO="0.00" LANGUAGE="" RATING="0" BPM="" TAGS=""

PUBLISHER="" ALBUMARTIST="Apex feat. Ayah Marar" COMPOSER="" COPYRIGHT=""

TRACKNUMBER="3" F1="" F2="" F3="" F4="" F5="" CASTTITLE="Apex feat. Ayah Marar - Space

Between Us" /></NEXTTRACK>

<PREVTRACK><TRACK ARTIST="Alix Perez Feat. Specific" TITLE="Drive by" ALBUM="Alix

Perez-PRG004 Vinyl" YEAR="2006" GENRE="Drum &amp; Bass"

COMMENT="Straight.from.da.Underground" FILENAME="C:\Muisic\Test\Alix Perez Feat.

Specific - Drive by.mp3" DURATION="05:47"  STARTED="2024-11-18 11:43:28" PLAYCOUNT="3"

 LASTPLAYED="2024-11-18 11:42:58" INTRO="0.00" OUTRO="0.00" LANGUAGE="" RATING="0"

BPM="" TAGS="" PUBLISHER="" ALBUMARTIST="Alix Perez Feat. Specific" COMPOSER=""

COPYRIGHT="" TRACKNUMBER="2" F1="" F2="" F3="" F4="" F5="" CASTTITLE="Alix Perez Feat.

Specific - Drive by" /></PREVTRACK>

</PLAYER>

%artwork - currently playing track artwork in PNG format, base64-encoded (Notifications only);

recommended to use with POST request type because of large data size. The Save Artwork option

must be enabled for this variable to work.

%user1 ... %user5 - custom user fields

%requestedmsg - requested song message when playing the requested song (Notifications only)

%temp, %humidity etc - all weather variables (change "?" to "%")

The title format string can include any number of the variables listed above along with any custom text or

special characters.

4.25.13 Repeat protection rules

To improve the quality of track selection when using Track List or Playlist Generator, the repeat protection

rules should be configured properly. The rules should not be too strict, because it places restrictions and

can lead to errors (e.g. inability to find a suitable track) and decreased performance.

In order to find the adequate values for the separation rules, please use the Repeat protection rules

testing tool. Open Music Library and click Tools -> Repeat Protection Rules Test. A window will

open:
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Repeat protection rules testing tool

Using the tool

1. Select the folder with music tracks.

2. Set the repeat protection rules that you want to test.

3. Set the number of tracks to select from the folder. It should be at least 5-10 times larger than there

are tracks in the folder.

4. Click the Test button and wait for the results.

Interpreting the results

When the rules are optimal, the "Min playcount", "Max playcount", and "Average playcount" will be about

equal. A difference of 1-3 tracks is acceptable.
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When the rules are sub-optimal, the difference between those values will be larger. It's still able to

create the playlist, but because the rules are too strict, it does not have many tracks to choose from

when selecting the next track. It will lead to some tracks being played more often than the others. 

If there are warnings, e.g. "WARNING! Unable to find suitable track; selecting a random track" it means it

can't create a playlist using the rules specified. 

In case of sub-optimal results, or errors, the rules should be made less strict by lowering the no-repeat

periods.

4.25.14 Containers

Containers allow to pack multiple tracks into one item. This is useful when you, for example, need to

create a non-breakable group of tracks.

Container item is cross-faded according to the tracks it contains. Fade in for the container item is equal to

fade in of the first track in the container. Fade out and mix are equal to fade out and mix of the last track

in the container. You can also pack ads playlists into a container. Container contents can be edited: right-

click it in the playlist, select Tools->Edit/rename.
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4.25.15 Time Stretch

Time Stretch adjusts the music track playback speed so that the last track of the hour ends at the end of

the hour. Changing the track speed does not affect its pitch. To see hour boundaries in the playlist, you

can enable Hour separation markers in the playlist window. 

To use the feature, in the top menus select Tools -> Time stretch.

In the Time Stretch window, you can adjust limitations on how much it can speed up or slow down the

tracks. Speed adjustment will not be applied if the required speed adjustment is outside the specified

percentage range.
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When speed adjustment is applied, you can see it in the # column in the playlist: a percentage will be

shown next to the track's number, e.g., "1. [+4.5%]" which means that the track will be playing faster by

4.5%.

To achieve better (and more precise) results when using this feature, it is recommended to process the

music tracks - Mix Point, and Trim Silence at least.



Part

V
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5 Settings

5.1 General

RadioBOSS allows users to customize many options as personal preferences.

To customize the general settings:

On the top menu bar, select Settings > Options...

The Settings dialog opens. 

In the General window, users can customize these settings:

Start with Windows

Run RadioBOSS at Windows startup. The Startup options window

allows you to set the program launch delay and modify a few other

settings.
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Restart the program if it

crashes or hangs

Program will be auto-restarted in case of fatal error, crash or hang.

The playback will be resumed automatically.

Ask on close A confirmation box will appear when you close RadioBOSS.

Start playlist Play first track in playlist when RadioBOSS is launched.

Resume playback Resume playback when RadioBOSS is launched.

Execute a command Execute a command after RadioBOSS is started

Place button in the

taskbar

Put the RadioBOSS button in the taskbar. By default, the option is

checked.

Sort Playlist by column

click

Sort a playlist by clicking on the columns (#, Start time, Title, Intro,

Outro, Time, etc.).

Sort scheduled events list

by column click

Sort scheduled events list by clicking on the columns.

Additional information

storage location

Set the location where additional track information (playcount, last

played, additional tag fields, ...) is stored.

Options:

· Track Tag (APEv2) 

· Database (SQLite) - default

· Database (MySQL)

For more information please refer to this page.

Remember playlist file

names

If checked the playlist file names for all playlist tabs will be

preserved between sessions.

Do not remove scheduled

tracks from the playlist on

exit

When you exit the program, the scheduled tracks will not be

removed from 

the playlist.

Remove stop commands

after execution
Remove "stop" commands from the playlist after they are executed.

Voice track folder Folder where voice tracks are saved. Only files from this folder are

treated as voice tracks.

Advanced configuration... Fine-tune RadioBOSS settings.
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Priority
Select a priority for RadioBOSS. High priority is recommended for

smooth playback, this is the default setting.

"X" button action
Set an action to be taken after clicking the Close button in the

upper-right corner.

Volume scale Select a volume scale look.

5.2 File types

To customize file types:

On the top menu bar, select Settings > Options... 

Select File Types category.

For more information, please refer to the Using different types of files topic.
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5.3 Playback

Playback device configuration.

To configure the playback properties, follow these steps:

1. On the top menu bar select Settings > Options...

2. Click Playback. 

In the Playback window, users can configure Playback Devices:

Main soundcard

Select the main output device that is to be used to play the

playlist and scheduled tracks.

RadioBOSS takes advantage of ASIO sound cards and

Windows 7 WASAPI interface.

Monitor soundcard

In addition to the Main soundcard, RadioBOSS can output the

same signal to another sound card. Disabled by default.
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Warning: do not select the same sound card for Main and

Monitor as this will lead to sound problems such as echoing.

Jingles device

Jingles will play on a different device. This setting only

affects the quick-access jinlgles, and not jingles in the

playlist.

If the "Main soundcard" is checked, the jingles will play on

the Main soundcard.

Cart wall device Carts will play on a different device.

If "Main soundcard" is checked, the jingles will play on the

Main soundcard.

Preview device

Select the "pre-listen" output device and speakers. 

Users can pre-listen to a track in the player window. To do

so, right-click a track from the playlist and from the context

menu, select Pre-listen.

AUX 1

AUX 2

Sound devices which can be used in AUX Players

Produce silent output when

nothing is playing

Produce silent stream when nothing is playing

When you click one of the "Change..." buttons, window will appear:
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Here, you can set the following:

Driver

Driver you want to use. 

Recommendations:

1) if you have an ASIO capable sound card, you may want to use ASIO output as

this will reduce the latency to a minimum.

2) if you're using Windows Vista, 7 or newer - choose WASAPI. Latency is very

low at this mode. This option is not available on Windows XP or prior.

3) otherwise, choose DirectSound

If your computer has no sound card or you want to use RadioBOSS for

encoding/decoding purposes only (for example, broadcasting) - choose "No

Device".

Device Choose the sound card you want to use. It might be a sound card that presents

in the system or a virtual card. 

Settings Set sound card settings:

Sample rate - sample rate in Hz, 48000 is the default.

Buffer size (ms) - buffer size, 50 ms recommended for WASAPI, 500 ms when

you're  using DirectSound. ASIO uses the sound card setting.



RadioBOSS User Manual168

Copyright 2025 DJSoft.Net. All rights reserved.

Output channels (ASIO only) - set channels on which you want to play the

sound. To unselect a channel, press DEL key on the keyboard.

Speakers - select the sound card speakers. For this option to work, with the

Windows Sound settings or sound card control panel you should set it to a multi-

speaker configuration. 

Exclusive - initialize the device in exclusive mode, else shared mode.

Recommended: unchecked.

Event-driven mode - enable event-driven buffering.

5.3.1 Miscellaneous

Miscellaneous playback settings:
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Remove gap between

tracks

Remove the gap between tracks. This will automatically remove

silence at the beginning and end of a track. Threshold setting

controls trimming levels.

ReplayGain Set how the ReplayGain tag should be treated. As an alternative,

we recommend using Normalization.

Smooth seeking Enable smooth seeking (with short fade)

Proxy for internet streams

playback

If you want to use a proxy for network streaming playback, enter

its address.

Low-pass filter/High-pass

filter

Enable Low-pass and high-pass filters if you need to, and set the

cutoff frequency.

Flash ending track This option will help you keep track of the countdown displayed

below the track currently on the air. When the specified number

of seconds before the end of the track is reached, the countdown

will start blinking red.

Exclude tracks shorter than You can exclude tracks shorter than the set duration that will blink

in red

during the countdown.

Resampling quality Default is 2 (16 point sinc interpolation). 3 is 32 point sinc

interpolation, and so on (higher is better).

5.3.2 Fading

Settings for crossfades, cart wall and voice tracking.

https://en.wikipedia.org/wiki/ReplayGain
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Do not fade out tracks

when playlist is in manual

mode

When "Stop after this track" button is pressed, the tracks will not

be faded out

Do not crossfade short

tracks

Tracks shorter than 45 seconds will not be crossfaded

Fade out on Stop Fade out starts when you click the Stop button. You can stop the

track immediately (without fading) by double-clicking the Stop

button.

Fade out on next track Fade out when the Next Track button is clicked. 

Crossfade curve shape Curve shape for the crossfades.

Linear - the music volume is changed linearly.
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Parabola Down (default) - the music volume follows the

downward parabola shape. 

Parabola Up - the music volume follows the upward parabola

shape. 

Cart wall Set the Cart Wall playback parameters

Voice Tracking Controls voice track playback
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5.3.3 Voice Tracking

Attenuate music Attenuate music while voice track is being played.

Voice track margin Set the margin to end the voice track before the track's Intro

point. 

Voice track bed When a voice track is playing without music, a bed will be used.

Default intro value

Default outro value

Set the default intro/outro value. Will be applied for music tracks

with no intro/outro values set. Default intro/outro values are not

counted for File Types (unless a file type has "Treas as a music

track" option enabled).

5.4 Input

RadioBOSS allows users to configure the microphone and line-in settings. These settings are used when

the line input is played with the Line.IN file, for MIC button and DTMF signal detection.
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To configure the microphone and line-in settings, follow these steps:

1. On the menu bar, select Settings > Options...

The Settings dialog opens.

2. Click Input.

MIC button
In this section, you set how the "MIC" button operates. The button is located in the bottom right corner of

the main window.

Click Change... and select the appropriate Driver (DirectSound/WASAPI/ASIO/Windows Mixer) and

Device - the sound card you want to use.

Note, that it is not recommended to use the "Windows mixer control", as the sound from the microphone

will not go on air if RadioBOSS is used to broadcast to the Internet. However, if an external application is

used to broadcast, the Windows mixer can be used.

Music level - playlist level when the microphone is on. Fade in/out sets how fast the volume is changed.

Level -50dB and below silence the music completely.
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Mic Amplifier - increase the microphone volume. If your microphone is too quiet, also check the sound

card settings (click Preview to test the setting).

Push-to-Talk - enable Push-to-Talk mode of operation for the Mic button (the microphone works as long

as you keep the button pressed down).

Output to encoders only - when enabled, you won't hear yourself in the speakers/monitors. But

listeners connecting to your station will hear you. If the echo is still present, disable microphone

monitoring in the sound card properties. If this option is on, we recommend alsoturning on the option

“Produce silent output when nothing is playing” in the playback settings.

Voice activated - when this feature is enabled, the microphone will be turned on automatically when

someone speaks into it.

The DSP button lets you assign different effects for the microphone. The "Apply main DSP to

microphone" controls if music DSP is also applied to microphone.

You can also assign effects for the microphone by right-clicking the MIC button. Please note that you

cannot use the same Winamp and VST plugins already used for music DSP.

Mic bed - set the bed to play when the mic is activated.

Line Inputs
Furthermore, users can select a driver and device for LINE.IN.

More information:

Enabling microphone

Working with linear input

5.5 View

RadioBOSS allows users to customize the look of a playlist window, change fonts and colors, change time

and track title format (12/24 hour) and more

To customize view settings, follow these steps:

1. On the top menu bar, select Settings > Options...

2. Click View. 
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Title format Track title format in the playlist. For example, if you want to

include album information, you may use this string:

%artist - %title - %album

"Filename" column Select what "Filename" column in the playlist should display.

Playlist items spacing Setup playlist items spacing.

Grid lines in a playlist Show grid lines in the playlist.

Horizontal grid lines only When grid in a playlist is enabled, show only horizontal grid lines.

Highlight item under mouse

cursor

Select item under mouse cursor.

Search list items spacing Setup search list items spacing.
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Include stream name in title

(when playing network

stream)

When playing an Internet stream include its title. If unchecked,

only the track title will be displayed.

Substitute network stream

URL

Change the stream URL to the text specified when sent in

notifications and nowplaying updates. 

Force 24h clock Turn this on if you want to have clochs in 24 hour format.

Otherwise it uses operating system format.

Show weather and humidity

in the main window

Show weather and humidity information in the main window. Click

on the label to change temperature units (Celsius or Fahrenheit).

Retrieving weather data.

Adjust clock Allows to adjust clock for RadioBOSS - it affects time display and

scheduled events.

"On air" visualization Visualization style in the "Now playing" bar. 

Waveform type sets how the waveform is built: using the average

or peak levels of a music track.

Turn off visualization/level

display

Turn this on to reduce CPU usage.

You can change the program's appearance in the "Style" section. 
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5.5.1 Style

To customize Style settings:

On the top menu bar, select Settings > Options... 

Select Style category. 
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This section allows you to change the appearance of the program's interface. You can choose a

preconfigured style from the Style list. 

You can also change style parameters: window and playlist font, color settings, button style, etc.

5.6 Silence detector

RadioBOSS allows you to define actions to be taken on silence (when nothing is playing in the playlist).

These settings can be configured in the Silence detector window.

Silence detector checks the output sound level and if it's below the defined threshold, it will perform an

action. 
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To configure the Silence Detector, follow these steps:

1. On the top menu bar, select Settings > Options...

2. Click Silence detector.

3. Toggle the slider to define the length of silence. For instance, if you set it to 10 seconds, then after 10

seconds of silence, the Silence Detector will perform an action.

4. The next step is to choose the action to take on silence. The program can play the next track, repeat

the current playlist or load an extra playlist for playback.

5. To enable the silence detector, check the On box.

6. Click OK.

More information:

Playback
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5.7 Broadcast

RadioBOSS enables broadcasting Internet radio for users who want to create their own internet radio

station. It is possible to set up any number  of output streams, each with its own unique configuration.

Broadcasting settings can be configured in the Settings dialog. 

Please refer to the Broadcasting Internet radio topic for more information on how to set up broadcasting.

The Advanced button allows you to set additional broadcasting settings.

Proxy server - specify the proxy server for broadcasting. Leave this empty unless you understand what

this setting is for. An incorrectly configured proxy server will block any connection attempts and

broadcasting will not work. Important! The proxy server needs to support the HTTP "CONNECT"

method.

More information:

Custom encoders
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5.7.1 Metadata

To customize the station info, follow these steps:

1. On the top menu bar, select Settings -> Options...

2. Click Metadata. 

Station info Fill in your station information

Broadcasting title format Sets the broadcasting title format. The format can include

multiple lines that will be rotated one by one. When multiple lines

are used, the Update title period should be set to "Periodic".

For possible values please see this page: Title format variables.

Update title When RadioBOSS should update the broadcasting title on the

server. 

The possible values are:

· Periodically - set the time interval in seconds to update the title

periodically
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· On track start - the title will be updated when track playback is

started

5.7.2 Custom encoders

Custom encoders - allows you to add any custom encoders. RadioBOSS can use any command line

encoder that supports input/output to console. 

Encoder command line parameters can include the following variables (the values correspond to the

encoder settings in RadioBOSS):

{SampleRate} - sample rate in Hz (e.g. 44100)

{KSampleRate} - sample rate in kHz (e.g. 44.1)

{Bitrate} - bitrate in kbps (e.g. 128)

{Channels} - number of channels (e.g. 2)

The encoder must be told (via the command-line) to expect input from STDIN, rather than a file, and to

send output to STDOUT.

The MIME type depends on the encoder file format.

RadioBOSS sends 16-bit signed PCM data to encoder, Little-Endian.

Example: command line for lame.exe MP3 encoder

<path>\lame.exe -r -s {KSampleRate} -b {Bitrate} --resample {KSampleRate} - -

Example: command line for ffmpeg encoder to encode in mp3

<path>\ffmpeg.exe -loglevel -8 -f s16le -ac {Channels} -ar {SampleRate} -i - -f mp3 -c:a libmp3lame -

b:a {Bitrate}k -

Example: command line to send uncompressed RAW PCM. pcmraw.exe encoder is located in the

Plugins folder where you have installed RadioBOSS (default C:\Program Files (x86)\RadioBOSS)

C:\Program Files (x86)\RadioBOSS\Plugins\pcmraw.exe - -
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5.8 Reports

RadioBOSS keeps a log of tracks that have been played. Moreover, the program can save the title of a

track which is currently being played to a file and upload this file to a specified FTP server. The program

can also use HTTP request to submit parameters of a current track to a specified URL address. The

parameters include artist, title, duration, genre, album and other information. It can also send

notifications of various events, such as errors, to an e-mail address. 

To set up log file settings, follow these steps:

1. On the top menu bar, select Settings > Options...

2. Click Reports.

By default, the reporting feature is enabled. You can set the program to include a track number into a

report and change the folder to save reports.

Add network stream track titles to the report - when a network stream is playing, track titles from

the network stream will be added to the report as separate tracks.
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You can set the program to save the title of a track which is being played to a file (nowplaying.txt) and

upload it to an FTP server. Track name is saved to the file in the format specified in View – Title format. 

RadioBOSS can convert characters for the nowplaying file based on the rules defined in the

textconversion.txt file. The file must be placed in the settings folder (to open it, use the Settings-

>Open Settings Folder menu command), there is an example file named textconversion-example.txt

with example rules.

Include Next Track info - if enabled, the nowplaying.txt file will contain the next track information as

well. 

Nowplaying file contents can created based on a template (select the Template option in the

nowplaying file type). The template file is located in the settings folder (to open it, in the menu click

Settings->Open Settings folder) in the Templates subfolder, nowplaying.txt.

The Save artwork turns on artwork export - for the current and next track. The artwork will be saved

as a PNG or JPEG image (depending on the extension specified for the file name, i.e. "\artwork.jpg" will

make it use JPEG format) and resized to be at most 400 pixels in size (the size can be changed in the

Advanced Settings). If a track does not have artwork embedded, no cover art will be saved. If you want

to specify cover art image for tracks with no artwork, press the Default Artwork button.

Copy to FTP - when enabled, RadioBOSS will upload nowplaying file and artworks to FTP server. To set

up an FTP server connection parameters, press the FTP Settings... button.

Artworks of previous tracks - if this option is enabled, the artworks of played tracks will be saved.

The file name must include the %N modifier - a numeric value will be substituted instead by the

software. RadioBOSS will save up to 20 covers of played tracks (the sequence number of each next

artwork is incremented by 1).

The program also allows using HTTP request to send current track information to a specific URL address.

It can also send notifications of various events such as: server connect and disconnect, silence detector

actions, errors.

Please see this page: Using notifications.

More information:

Broadcasting internet radio

5.8.1 Nowplaying notifications

Notifications are used to send various information to a script or to an e-mail address. This can be useful

when you want to display the current song name on your website.

To use HTTP request or E-mail notifications:

1. Turn on the feature: check the "Enable notifications" checkbox. If you plan on using E-mail

notifications, click the E-mail settings... button and fill the SMTP e-mail server 
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2. Click the "+" button to add new notification. 

3. The notification window will appear:
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Enter a URL (http://) into the URL/e-mail field if you want to send a notification to a script.

HTTP notifications

For the "Playing track title" notifications, you should fill the URL with the required parameters, e.g.:

http://example.com/updatesonginfo.php?artist=%artist&title=%title

The Encoding depends on what your script accepts. UTF8 works in most cases and it doesn't have a

problem with international characters.

Run a program 

You can run a program when a track starts in RadioBOSS, enter the "run" keyword, followed by a

command to execute. 

For example: run C:\Path\To\Program.exe "%casttitle"

Variables

The values can be used in a request for a Playing Track Title notification: Title format variables

For other notification types, use these parameters:

%msgtype - message type: server for server connect/disconnect messages; silence for silence

detector messages and error for error notifications

%msgtext - message text

E-mail notifications

To send notification to an e-mail address, enter the address in the URL/e-mail field. Multiple addresses

can be specified, separated by a comma.
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The Configuration Wizard button makes it easier to set up Tune In and Twitter integration.

5.9 Video

RadioBOSS can play not only audio tracks but also video. Video playback can be configured in the

Settings dialog. Video playback is supported in RadioBOSS Advanced only.

To customize video playback settings:

On the top menu bar, select Settings -> Options... 

Select Video category. 

Display the video window when video playback begins - a screen with an image will appear when

you play the video track. If you don't need it, disable this option.

Show video in fullscreen on monitor - the video will be displayed in fullscreen mode on the selected

monitor. Press a key F4 to exit fullscreen mode.
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5.10 Controls

This window allows to select play and mouse double-click function; hide unneeded buttons.

To customize Controls settings:

On the top menu bar, select Settings > Options... 

Select Controls category 

 

5.11 DTMF

To customize DTMF detector settings:

On the top menu bar, select Settings > Options... 

Select DTMF category.



Settings 189

Copyright 2025 DJSoft.Net. All rights reserved.

Check DTMF on Select the source where DTMF signals will be checked - one of

the linear inputs or network stream URL.

Minimum DTMF signal level Specify the minimum threshold for DTMF signal.

DTMF checking frame Specify the time frame during which RadioBOSS will look for

DTMF tones. The "before" and "after" options are related to the

event start time. 

Delay event startup Delay the event startup when DTMF is detected (seconds).

Skip DTMF exit if any of the

following file type are

playing

When DTMF Exit is detected, it will let selected file types continue

playing (e.g. commercials) instead of interrupting the event. The

rest of the items inserted by the same event will be removed from

the playlist.

For more information on DTMF please refer to this topic: Starting events by DTMF signal
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5.12 API

To customize Remote Control API settings:

On the top menu bar, select Settings > Options... 

Select API category. 

Enable Remote Control Enable or disable remote control feature

Listen on port Select the port where connections will be accepted

Allow connections for

localhost only

Allow only connection from the same computer where RadioBOSS

is installed. Enabled this is you don't need remote access.

Password Specify password - only requests with the correct password will

be executed.

Security notice: choose a complex and impossible to guess

password to prevent any unauthorized access. 
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Using the HTTPS protocol

Remote API can be used over the https:// protocol (supports TLS 1, TLS 1.1, TLS 1.2). In order to

activate it, please copy the certificate files to the RadioBOSS's settings folder (to open the folder, in the

menu click Settings->Open Settings folder).

Certificate files must be in the PEM format. The files must be named as follows:

· cert.pem - the certificate

· cert.key - certificate key 

· root.pem - root certificate chain (optional)

See this topic for more information on how to use Remote Control API: Remote Control API

5.13 Scheduler

To customize Scheduler settings:

On the top menu bar, select Settings > Options... 

Select Scheduler category. 
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Playlist fade in/fade out duration while starting an Overlay event - Set the fade type for

scheduler events with Overlay Playback option or Jingles. This option controls how smooth the playlist

volume change would be.

Scheduler event flashing time - Set the time for a scheduled task to flash in the Coming Up Next

window before its playback starts.

Maximum time to generate playlist by schedule - Timeout when using the "Generate" command in

the scheduler event. If a playlist is not generated within the specified timeout, the playlist generator is

aborted. Usually 10 seconds is enough.

Do not start any scheduled events when the playlist is currently paused - If the playlist is

currently paused, the event will not be started (*).

Do not start any scheduled events when the playlist is currently stopped - If the playlist is

currently stopped, the event will not be started (*).

Do not start scheduled events when MIC is on - If the MIC is on, the event will not be started (*).

(*) - Events are still inserted into the playlist, but their playback will not start.

Send track titles from Overlay events - titles from events that are played as Overlay will be sent to

the streaming server (in case when the playlist is paused or its volume is set to zero).

Sweeper selection: allowed duration deviation (sec) - When selecting sweepers before scheduled

events, allow the sweeper duration to be larger by up to set amount.

Weather data source - select a service to get the data from: OpenWeatherMap or AccuWeather.

AccuWeather is the default and does not require entering the API key. API key should be entered for

OpenWeatherMap to avoid rate limitations.

More information

Automatic Weather Announcements

5.14 Relay

To customize Relay settings:

On the top menu bar, select Settings > Options... 

Select Relay category. 
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Wait for the current track

to finish

When the relay stream becomes active, it will not be played

immediately but wait for the current playing track to finish.

Max time to wait Maximum time to wait for the current track to finish, when the

time elapses, relay playback will start.

Relay title format Title format when relay is active. Can include any custom text. 

The %relaytitle variable holds the title from the relayed

stream.

Playlist fade out (fade in)

when relay starts (stops)

Fading settings for smooth transition between playlist and relay.

Relay fade in Fade in when relay starts

Playlist volume when relay is

connected

Set the playlist voluime when relay is active and connected
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Start next song when the

relay stops

Start the next song in the playlist when the relay stops

Silence Threshold

Silence Duration

Silence detector settings when relay is considered inactive. Only

applied when relaying linear input and not used when relaying

network stream.



Part

VI
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6 User interface

RadioBOSS' user interface overview:

1. Top menus

Top menus provide quick access to most of the commands and options of the program. 

For more information on the top menus, please refer to Top menus.

2. Toolbar

Toolbar provides a one-click access to all commands and options of the program which are presented as

icons.

For more information please refer to Toolbar.

3. Control panel

Control panel allows users to switch between views and modes that are presented as tabs.
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For more information, please refer to the Control panel.

4. Playlist window (Zone 1)

Playlist window lists all the tracks in a current playlist along with track information.

For more information on playlists, please refer to the Playlist window.

5. Zones 2 and 3

Additional zones can be activated from the menu: View -> Work Zones

Zones 2 and 3 can host Cart Wall, AUX Player, Web browser, Search, Notepad and File Explorer.

An additional work zone is placed in a separate window and can be used on a different monitor, for

example.
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6. Player

The player allows users to play a track from a playlist and provides additional options to control playback.

For more information on the top menus, please refer to the Player.

The style of the playback buttons can be changed in Settings->View, Playback button style.

You can change your radio station's logo. Just right-click on the icon in the upper right-hand corner. A

window will open in which you can select a new logo. There is a Default caption above the logo - this is

the name of the current profile. You can change it by saving the profile under a different name: press

Settings -> Save Profile As.
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More information:

Top menus

Toolbar

Control panel

Playlist window

Player

6.1 Top menus

RadioBOSS offers top menus that provide access to all the commands and options.

Description of menus:

File Create, open, save, print a playlist

Edit Operations with playlist
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View Viewing and control panel options

Playlist Add music and other items to a playlist, record voice tracks and more

Tools Tools: Music Library, Report Generator, Ads Scheduler, Stream Archive

Jingles Configure quick access jingles

Settings Settings and operations with a profile

Help Help, registration, program credits

User User access control

6.1.1 File

The File menu allows users to create, open and save a playlist. 

Description of menu entries:

New Create a new playlist

Open... Open a playlist

Save Save a playlist

Save as... Save a playlist as...

Export/Print... Print a playlist

Exit Exit the program
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6.1.2 Edit

The Edit menu allows users to edit a playlist, such as cut, copy, paste and delete playlist items.

Description of menu entries:

Undo Undo a recent operation

Cut Cut a selected file to clipboard

Copy Copy a selected file to clipboard

Paste Paste a file from clipboard

Select all Select all files

Crop selected Crop selected files

Delete Delete a selected file

Delete all Delete all files

6.1.3 View

The View menu allows users to switch to different viewing modes, such as File explorer, Search,

Information, FX, Broadcasting statistics, etc.
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Description of menu entries:

File explorer Open a file explorer window

Search Open a search window

Schedule Open a scheduler

FX Open an FX control panel

Work Zones Configure the number of work zones. Second and third work zone will appear at

the right and can host File explorer, Search, Cart wall, AUX Player and Web

browser

Track

Information

Turn on/off Track Information panel under the playlist
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Left panel Show/hide left panel

MIC and VU

meter in the

centre

Show/hide MIC and VU meter in the centre

Status bar Show/hide status bar

Tool bar Show/hide toolbar

Top panel Full/Minimal/Hide top panel

Full Screen Switch to full-screen mode 

Colors and

Fonts...

Change playlist colors and fonts

Playlist

columns...

Configure playlist columns

Playlist auto-

scroll

Automatically scroll playlist to the playing track

Selection

follows

playback

When checked, currently playing track will be selected automatically

Track

information

follows

playback

Update the Track Information tab with current track information

Accessibility

(Screen

Reader)

Turn on/off accessibility mode - improve UI accessibility for Screen Reader

users

Language Select a language for the user interface

6.1.4 Playlist

The Playlist menu allows users to perform operations on a playlist. 
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Description of menu entries:

Playlist Generator Pro... Open Playlist Generator Pro

Add file... Add a file to the playlist

Add folder... Add all tracks from a specified folder to the playlist

Add URL... Add an URL address to the playlist to play a network stream or

podcast

Add command... Add a command to the playlist

Add timed pause... Add timed pause (a window will open where you can set the

duration)

Add teaser... Add Teaser
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Add time announcement... Add automatic time announcement

Add comment... Add comment to the playlist. Comments are for the convenience

only, they are not played.

Add Line Input... Add a line input to the playlist. This menu item will be hidden if no

device is selected for Line.In in Settings

Insert playlist Insert a playlist to the current playlist - the playlist will appear as

one track and will be opened up on playback

Add tracks from playlist... Add tracks from a playlist to the current playlist

Insert voice track... Insert voice track into playlist, voice tracks are recorded using

Voice Track recording tool

Record voice track... Open Voice Track recording tool

Add Track List... Add Track List

Track List Repeat

Protection...

Configure no-repeat rules for Track List feature

Extra

Add Text-to-Speech... Read custom text.

Add DTMF tone generator Add DTMF tone generator.

Show Duplicates Show duplicate tracks in the playlist. Option 

Show nonexistent files Mark non-existent files in the playlist

Shuffle Shuffle tracks in the playlist

Reload tracks information Force reloading tags and additional information for all tracks in

the playlist.

Copy to folder... Copy selected files to a folder. If all tracks in a playlist are

selected, copied tracks will have a number (track number) in the

file name. This way, you can keep the same track order in the

folder as in the playlist.
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Delete files from disk Delete selected files from disk. Use with care

Playlist Generator... (deprecated) Open old Playlist Generator

Reset played state Reset "played" state for tracks in the playlist window

Sweeper repeat protection Repeat protection for scheduler Sweepers

Notepad...(T) Open Notepad to add note to the track. The note will pop up

every time the track is played. Right-click the notepad window to

change its mode of operation (per-track note or sticky note).

Find... Search in playlist

More information:

Generating a playlist

Using microphone

Working with linear input

Using Track list

Voice Tracking

6.1.5 Tools

Menu entries:

Music Library Open Music Library
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Report Generator Open Report Generator

Ads Scheduler Open Ads Scheduler

Auto Intro Open Auto Intro settings

Broadcasting statistics... Open a window with information on broadcasting output channels

(number of listeners, status)

Set cast title... Change streaming title on the server.

Playback queue... Open a window with Playback queue

Song requests... Open a window with Song requests

Time stretch... Configure Time Stretch

Render playlist to a file... Mixdown a playlist

Stream Archive Configure Stream Archive feature to record broadcasts

6.1.6 Jingles

The Jingles menu lists current jingles (1-0) and allows users to define new ones.

Jinlges may be quickly played using the numeric 1..0 keys on keyboard or using the 1..0 buttons on the

toolbar. All playing jingles can be stopped by pressing the "minus" button.

Description of menu entries:
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1-0 List of assigned jingles

Assign... Assign jingles

6.1.7 Settings

The Settings menu allows users to save and load settings profiles, customize hot keys and preferences.

Description of menu entries:

Save profile Save a current settings profile

Load profile Load a settings profile

Delete profile Delete a settings profile

Save profile

automatically

Save profile automatically

Open Settings

folder

Opens the folder where RadioBOSS stores its settings and other data

Open Reports

folder

Opens the folder with reports. Report is a .csv file that stores the log of

program operation: what tracks were played, when, which scheduled tasks

were started and other events

Settings backup

and restore

Create a backup copy of settings: profile, playlists, scheduled events and

other settings in a single file
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Hot keys Customize hot keys

Crossfades Configure crossfades

Options... Open the Settings dialog

More information:

RadioBOSS. Quick start

6.1.8 Help

The Help menu allows users to open Help, visit RadioBOSS website, report a bug, register the program

and view credits.

Description of menu entries:

Contents Open Help system

Getting Started Open RadioBOSS Quick start chapter

RadioBOSS Web Site Open the RadioBOSS website

Community Forums Opens RadioBOSS Community Forums

Contact support... Open the Report a bug form, contact support

Check for Updates Check if a new RadioBOSS version is available
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Automatically check for

updates

Check if a new RadioBOSS version is available automatically

Buy RadioBOSS Open the RadioBOSS purchase page

Enter Registration Code... Open Enter registration key dialog

About... Open About RadioBOSS dialog

More information:

How to register

6.1.9 User

User Account Management. Please see this topic for more information.

6.2 Control panel

Description of icons:

File explorer - Browse through the file system to add tracks to the playlist (Read more...)

Search - Find a track instantly by searching for a specific keyword in title, artist, album, etc

(Read more...)

Scheduler - Events Scheduler (Read more...)

FX - Configure the equalizer, tempo, ...  (Read more...)

6.2.1 File explorer

File explorer allows users to browse through folders and add files to the playlist.
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To add a track to the playlist, drag a file from File explorer and drop it to the Playlist window.

Alternatively, you can press the Insert key. 

List can be manually updated by pressing the F5 key.

Right-click any item in the file list to enable "Quick access folders" feature. 
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You can enable tree view of the files list from the View settings. 

6.2.2 Search

Search allows users to find a track in the Music library or folder. 
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Click the Select... button (on the right) to select the the search source: one of the music libraries or a

folder. Search in a folder covers the folder itself and its subfolders.

To search for a file, enter a keyword into the Find field.

As the first letters of a keyword are being entered, the program automatically queries its database and

lists all the tracks that match the query. The results narrow down as the user keeps on entering letters.

Users can search for a keyword in title, artist, album, year, genre, comment, etc.

To add files to playlist you may use drag-n-drop, right-click menu or hot keys:

Num+ or Insert add after playing file

Num- add to the end of playlist

Right-click the Stop button to show the contents of the whole library in the search result.

You can prelisten a track. To do this, hold down Alt and click on the track (or press Alt+R).

More information:

Creating a music library

6.2.3 Scheduler

Scheduler allows users to schedule a track, playlist, or command for automatic playback at a predefined

time.

Right-click the list header to select visible columns.
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Description of scheduler buttons:

On
Enable/disable the scheduler. Button will be grayed out when the scheduler is suspended

by the "scheduler off" command.

Manual The event won't start automatically. Instead, the program will only notify when event is

supposed to be started. To start the event use "Run Now" button.

Run

Now
Run selected scheduler event manually

Add... Add a new scheduled event

Edit... Edit a scheduled event

Delete Delete a scheduled task

List ? Submenu with list edit commands

Save Save a list of scheduled tracks to a file (.sdl)

Load Load a list of scheduled tracks from a file (.sdl)

Print Print scheduled events
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Import Adds events from .sdl files to a list

Clear Clear event list

Description of column headers:

Run in Time left before a scheduled start of a task

Date Date for a scheduled event to run (if used)

Time Time of scheduled start

Imm Status of the Launch immediately option ("+" - enabled, "-" - disabled)

A
Status of the Play above the air option ("+" - enabled, "-" - track will be included into

the main playlist)

Mute

level
Playlist volume level when "Play above the air" task is being played

Filenam

e
Filename and path to a file in the file/command name

Name Event title

More information:

Scheduling playback

6.2.4 FX

FX allows users to configure various effects.
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On this tab you'll see the current output level and control it using Gain slider. You can also add, remove

turn on and off DSP's. 

To add DSP: click "+" button; click "-" to remove and tool button to configure.

You can use built-in DSP's such as Equalizer and Compressor; you can also use VST and Winamp DSP

plugins.

Right-click the Level Meter to change its signal source and set its mode of operation.

Information on status of AutoAmp (Automatic Gain Control) and Gap killer. Click buttons to

access settings of those features.

To change Gap Killer or AutoAmp settings, click the corresponding button.

More information:

Using the microphone

DSP Plugins

6.3 Work zones

Work zones can host File explorer, Search, Cart wall, AUX Player, broadcasting statistics, notepad and

Web browser. To configure work zones use the menu command: View -> Work Zones.

Work zones are marked Zone 1, Zone 2 and Zone 3 on the screenshot. Additional work zone in a

separate window and on the left side of the main window can also be used.



User interface 217

Copyright 2025 DJSoft.Net. All rights reserved.

6.3.1 AUX Players

AUX players are mini playlists with simple playback and edit features. Those players can be used for

various purposes: save and edit playlists, play tracks, jingles or announcements. 

AUX players can only be added in Zone 2 or Zone 3.  In order to activate those zones use the menu

command: View->Work Zones->2 (or 3).

It's possible to drag-n-drop tracks between regular and AUX playlists: just start dragging a track by its

icon (please see the Playlist page for details).

By default, AUX players play tracks on the Main sound device. It's also possible to use other devices. Click

the Settings button to configure AUX player. If an AUX1 or AUX2 device is selected for the playback,

make sure those devices are correctly configured in the Playback settings.

6.3.2 Cart wall

Cart wall is used for instant on-demand playback of various audio files. 

6.4 Toolbar

RadioBOSS offers a toolbar that provides quick access to the main commands and options.

Description of icons:

Create a new playlist
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Open a playlist

Save a playlist

Save a playlist as...

Cut to clipboard

Copy to clipboard

Paste from clipboard

Undo a recent operation

Hide or show left panel

Work zones: 1

Work zones: 2

Work zones: 3

Work zones: Additional

Add track

Insert a playlist - playlist will be added as one item in the program's playlist and will open up

on playback

Insert tracks from playlist

Add tracks from folder

Playlist generator

Music library

Ads Scheduler
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Report Generator

Record the broadcast 

Broadcasting statistics

Turn broadcasting on/off (hot key can also be used: Ctrl+E)

Open the Settings dialog

6.5 Playlist window

Playlist window lists all of the tracks in a current playlist along with the track information. 

Playlist columns are configurable from the menu: View -> Playlist columns (alternatively, you can right-

click a column header). 
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You can perform different actions with tracks by clicking the corresponding icon in the playlist:

 Prelisten a track

 Remove a track

 Play a track

 Add a Stop command after a track

The Listeners columns shows the current number of listeners and changes from the previous track.

By default, there are two playlist tabs. You can create as many playlists as you need, just click the "+"

button on the right. 

Right-click on a playlist tab to rename, delete it, or set additional options:
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Queue mode - when enabled, the tracks will be deleted from the playlist after playback. The tracks will

not be deleted if either Repeat Track or Repeat List options are enabled.

Show hour separation markers - enable automatic hour markers.

If you would like to make a playlist non-playable, right-click its tab and check the Non-playable playlist

option.

Set Active playlist - marks playlist as active playlist. Scheduled events are inserted into the active

playlist.

Tracks in the playlist are marked with a blue note icon. Tracks which have already been played have a

grayed out icon. Scheduled tracks in addition have the small "clock" icon.

Various file types (commercials, station IDs, jingles, ...) can be marked with color.

You can drag files inside a playlist using a mouse or using keyboard: Ctrl+Down arrow, Ctrl+Up arrow.

You can drag files between different playlists (eg. to an AUX playlist).

You can add tracks to the playback queue. Just right-click on a track and select Add to playback

queue. The track's number in the queue will be displayed next to the track. 

Below the playlist, there is an area for information about tracks. You can editing tags in that area.

To prelisten a track: hold down Alt and click on the track. 

You can set a rating and a file type for each track. To do it, right-click the playlist and select the

“Tools” item. Rating can also be set using a hot key: Ctrl+Shift+Number (0-9)
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You can also set a file type via the music library: select one or more tracks, right-click a track in the

music database, and select “Track Properties...”

A cover art for the selected track is shown in the information area. For tracks without pictures, you can

put an image file named nocover.png into the settings folder: this picture will be shown in the Track

information field for tracks without cover art. To open the settings folder, select Settings –> Open

Settings folder in the menu.

More information:

Cart wall

File types

6.6 Playback control

Control playlist playback.
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The button style can be changed in the View section of the settings page. 

Seeking: the track playback position can be changed by right-clicking on the "On air" window. 

Color indication in the OnAir window: red vertical line shows Mix point, blue bars at the beginning

and end - fade in/fade out, pink bars - intro and outro.

Description of player controls:

Previous track

Play the selected track

Next track

Pause playback

Stop playback

Repeat the current track. Right-click this button for additional options.

Stop playback after the current track. Right-click this button for additional options.

Shuffle playback order. Attention! If your playlist contains tracks from the scheduler, random

playback order won't work: tracks will be played in order!

Repeat the playlist

Volume control.
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More information:

Generating a playlist

Playback queue

6.7 Hot Keys

To open settings hot keys click Settings -> Hot keys.

If you want to change any of the hot keys, click on the image of the key and select the characters you

would like to use. 

Additional hot keys

Ctrl+E - start or stop broadcasting.

Ctrl+NumPad(0..9) - set track rating (1-9 - set rating 1 to 9 respectively, 0 - set rating 10,

Ctrl+NumMinus - reset rating). 

Ctrl+, / Ctrl+. - seek playback position (+-10 seconds)



Part

VII
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7 License agreement

End-User License Agreement ("Agreement")

Last updated: November 22, 2020

Please read this End-User License Agreement carefully before checking the "I accept" checkbox, downloading or using

RadioBOSS.

Interpretation and Definitions

==============================

Interpretation

--------------

The words of which the initial letter is capitalized have meanings defined under the following conditions. The following

definitions shall have the same meaning regardless of whether they appear in singular or in plural.

Definitions

-----------

For the purposes of this End-User License Agreement:

 * Agreement means this End-User License Agreement that forms the entire agreement between You and the Company

regarding the use of the Application.

 * Application means the software program provided by the Company downloaded by You to a Device, named RadioBOSS

 * Company (referred to as either "the Company", "We", "Us" or "Our" in this Agreement) refers to Dmitry Vladimirovich

Kuzmitsky (INN 344813500018).

 * Content refers to content such as text, images, or other information that can be posted, uploaded, linked to or otherwise

made available by You, regardless of the form of that content.

 * Country refers to: Russia

 * Device means any device that can access the Application such as a computer, a cellphone or a digital tablet.

 * Third-Party Services means any services or content (including data, information, applications and other products services)

provided by a third-party that may be displayed, included or made available by the Application.

 * You means the individual accessing or using the Application or the company, or other legal entity on behalf of which such

individual is accessing or using the Application, as applicable.
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Acknowledgment

==============

By checking the "I accept" checkbox, downloading or using the Application, You are agreeing to be bound by the terms and

conditions of this Agreement. If You do not agree to the terms of this Agreement, do not check the "I accept" checkbox, do

not download or do not use the Application.

This Agreement is a legal document between You and the Company and it governs your use of the Application made available

to You by the Company.

The Application is licensed, not sold, to You by the Company for use strictly in accordance with the terms of this Agreement.

License

=======

Scope of License

----------------

The Company grants You a revocable, non-exclusive, non-transferable, limited license to download, install and use the

Application strictly in accordance with the terms of this Agreement.

The license that is granted to You by the Company is solely for Your purposes strictly in accordance with the terms of this

Agreement. 

Trial period

------------

You may download and use the Application for free during the trial period. During the trial period, the Company grants You a

limited, non-exclusive, non-transferable, non-renewable license to copy and use the Application for evaluation purposes only

and not for any commercial use. At the Company's discretion, the Company may provide limited support through email or

discussion forums. The evaluation copy of the Application contains a feature that will automatically disable the Application at

the end of the trial period. The Company will have no liability to you if this feature disables the Application. The evaluation

copy of the Application may disable or modify certain Application's features during the trial period. 

License key

-----------

Upon your payment of the license fee, the Company provides you with a registration number ("License key") and grants you a

limited, non-exclusive, non-transferable license to install and use up to five copies of the Application on one stand-alone

Device, on up to three Devices.

License Restrictions

--------------------

You agree not to, and You will not permit others to:

 * License, sell, rent, lease, assign, distribute, transmit, host, outsource, disclose or otherwise commercially exploit the

Application or make the Application available to any third party.
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 * Modify, make derivative works of, disassemble, decrypt, reverse compile or reverse engineer any part of the Application.

 * Remove, alter or obscure any proprietary notice (including any notice of copyright or trademark) of the Company or its

affiliates, partners, suppliers or the licensors of the Application.

Intellectual Property

=====================

The Application, including without limitation all copyrights, patents, trademarks, trade secrets and other intellectual property

rights are, and shall remain, the sole and exclusive property of the Company.

The Company shall not be obligated to indemnify or defend You with respect to any third party claim arising out of or relating

to the Application. To the extend the Company is required to provide indemnification by applicable law, the Company shall be

solely responsible for the investigation, defense, settlement and discharge of any claim that the Application or your use of it

infringes any third party intellectual property rights.

You agree to be identified as a user of the Application and agree that the Company may refer to you by name, trade name

and trademark (if applicable) and may briefly describe your business in the Company's marketing materials and web site. If

this clause breaches your company policy or you do not wish to be bound by this clause, the Company is happy to remove it

upon request.

Modifications to the Application

================================

The Company reserves the right to modify, suspend or discontinue, temporarily or permanently, the Application or any

service to which it connects, with or without notice and without liability to You.

Updates to the Application

--------------------------

The Company may from time to time provide enhancements or improvements to the features/functionality of the Application,

which may include patches, bug fixes, updates, upgrades and other modifications.

Updates may modify or delete certain features and/or functionalities of the Application. You agree that the Company has no

obligation to (i) provide any Updates, or (ii) continue to provide or enable any particular features and/or functionalities of the

Application to You.

You further agree that all updates or any other modifications will be (i) deemed to constitute an integral part of the

Application, and (ii) subject to the terms and conditions of this Agreement.

Maintenance and Support

-----------------------

The Company does not provide any maintenance or support for the download and use of the Application. To the extent that

any maintenance or support is required by applicable law, the Company shall be obligated to furnish any such maintenance or

support.
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Third-Party Services

====================

The Application may display, include or make available third-party content (including data, information, applications and other

products services) or provide links to third-party websites or services.

You acknowledge and agree that the Company shall not be responsible for any Third-party Services, including their accuracy,

completeness, timeliness, validity, copyright compliance, legality, decency, quality or any other aspect thereof. The Company

does not assume and shall not have any liability or responsibility to You or any other person or entity for any Third-party

Services.

You must comply with applicable Third parties' Terms of agreement when using the Application. Third-party Services and links

thereto are provided solely as a convenience to You and You access and use them entirely at your own risk and subject to

such third parties' Terms and conditions.

Term and Termination

====================

This Agreement shall remain in effect until terminated by You or the Company. The Company may, in its sole discretion, at any

time and for any or no reason, suspend or terminate this Agreement with or without prior notice.

This Agreement will terminate immediately, without prior notice from the Company, in the event that you fail to comply with

any provision of this Agreement. You may also terminate this Agreement by deleting the Application and all copies thereof

from your Device or from your computer.

Upon termination of this Agreement, You shall cease all use of the Application and delete all copies of the Application from

your Device.

Termination of this Agreement will not limit any of the Company's rights or remedies at law or in equity in case of breach by

You (during the term of this Agreement) of any of your obligations under the present Agreement.

Indemnification

===============

You agree to indemnify and hold the Company and its parents, subsidiaries, affiliates, officers, employees, agents, partners

and licensors (if any) harmless from any claim or demand, including reasonable attorneys' fees, due to or arising out of your:

(a) use of the Application; (b) violation of this Agreement or any law or regulation; or (c) violation of any right of a third

party.

No Warranties

=============

The Application is provided to You "AS IS" and "AS AVAILABLE" and with all faults and defects without warranty of any kind.

To the maximum extent permitted under applicable law, the Company, on its own behalf and on behalf of its affiliates and its

and their respective licensors and service providers, expressly disclaims all warranties, whether express, implied, statutory or

otherwise, with respect to the Application, including all implied warranties of merchantability, fitness for a particular purpose,

title and non-infringement, and warranties that may arise out of course of dealing, course of performance, usage or trade
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practice. Without limitation to the foregoing, the Company provides no warranty or undertaking, and makes no

representation of any kind that the Application will meet your requirements, achieve any intended results, be compatible or

work with any other software, applications, systems or services, operate without interruption, meet any performance or

reliability standards or be error free or that any errors or defects can or will be corrected.

Without limiting the foregoing, neither the Company nor any of the company's provider makes any representation or warranty

of any kind, express or implied: (i) as to the operation or availability of the Application, or the information, content, and

materials or products included thereon; (ii) that the Application will be uninterrupted or error-free; (iii) as to the accuracy,

reliability, or currency of any information or content provided through the Application; or (iv) that the Application, its servers,

the content, or e-mails sent from or on behalf of the Company are free of viruses, scripts, trojan horses, worms, malware,

timebombs or other harmful components.

Some jurisdictions do not allow the exclusion of certain types of warranties or limitations on applicable statutory rights of a

consumer, so some or all of the above exclusions and limitations may not apply to You. But in such a case the exclusions and

limitations set forth in this section 11 shall be applied to the greatest extent enforceable under applicable law. To the extent

any warranty exists under law that cannot be disclaimed, the Company shall be solely responsible for such warranty.

Limitation of Liability

=======================

Notwithstanding any damages that You might incur, the entire liability of the Company and any of its suppliers under any

provision of this Agreement and your exclusive remedy for all of the foregoing shall be limited to the amount actually paid by

You for the Application or through the Application.

To the maximum extent permitted by applicable law, in no event shall the Company or its suppliers be liable for any special,

incidental, indirect, or consequential damages whatsoever (including, but not limited to, damages for loss of profits, loss of

data or other information, for business interruption, for personal injury, loss of privacy arising out of or in any way related to

the use of or inability to use the Application, third-party software and/or third-party hardware used with the Application, or

otherwise in connection with any provision of this Agreement), even if the Company or any supplier has been advised of the

possibility of such damages and even if the remedy fails of its essential purpose.

Some states/jurisdictions do not allow the exclusion or limitation of incidental or consequential damages, so the above

limitation or exclusion may not apply to You.

Severability and Waiver

=======================

Severability

------------

If any provision of this Agreement is held to be unenforceable or invalid, such provision will be changed and interpreted to

accomplish the objectives of such provision to the greatest extent possible under applicable law and the remaining provisions

will continue in full force and effect.

Waiver

------

Except as provided herein, the failure to exercise a right or to require performance of an obligation under this Agreement

shall not effect a party's ability to exercise such right or require such performance at any time thereafter nor shall be the

waiver of a breach constitute a waiver of any subsequent breach.
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Product Claims

==============

The Company does not make any warranties concerning the Application.

United States Legal Compliance

==============================

You represent and warrant that (i) You are not located in a country that is subject to the United States government embargo,

or that has been designated by the United States government as a "terrorist supporting" country, and (ii) You are not listed

on any United States government list of prohibited or restricted parties.

Changes to this Agreement

=========================

The Company reserves the right, at its sole discretion, to modify or replace this Agreement at any time. If a revision is

material we will provide at least 30 days' notice prior to any new terms taking effect. What constitutes a material change will

be determined at the sole discretion of the Company.

By continuing to access or use the Application after any revisions become effective, You agree to be bound by the revised

terms. If You do not agree to the new terms, You are no longer authorized to use the Application.

Governing Law

=============

The laws of the Country, excluding its conflicts of law rules, shall govern this Agreement and your use of the Application. Your

use of the Application may also be subject to other local, state, national, or international laws.

Entire Agreement

================

The Agreement constitutes the entire agreement between You and the Company regarding your use of the Application and

supersedes all prior and contemporaneous written or oral agreements between You and the Company.

You may be subject to additional terms and conditions that apply when You use or purchase other Company's services, which

the Company will provide to You at the time of such use or purchase.

Contact Us

==========

If you have any questions about this Agreement, You can contact Us by email: support@djsoft.net

More information:
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How to register
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8 Contacts

If you have questions about RadioBOSS, suggestions on how to improve the software, or you found a

bug, please visit our support page: http://www.djsoft.net/enu/support.htm or forums:

http://www.djsoft.net/smf/

The latest version of the program can be downloaded from http://www.djsoft.net

http://www.djsoft.net/enu/support.htm
http://www.djsoft.net/smf/
http://www.djsoft.net
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